Backspace not working

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Backspace not working

Matthew.Hinman
...
Hiya,
I did something to mess up my vim config, backspace used to work just fine
(delete the character to the left of the cursor). Now it doesn't do anything in
insert mode. I tried the ":fixdel" command, but that doesn't fix it. I also
tried using "stty erase ^H", that didn't work either. Finally I tried the "echo
"keycode 14 = BackSpace" | loadkeys" command, but that didn't fix it either.

Is there anything else that I should try? It's very frustrating not being able
to backspace.

Thanks,
Matthew Lee Hinman
Reply | Threaded
Open this post in threaded view
|

Re: Backspace not working

Aaron Griffin
> Is there anything else that I should try? It's very frustrating not being able
> to backspace.
What terminal are you using? does backspace work outside vim?

did you mess with /etc/inputrc (~/.inputrc)? try hitting
Ctrl+v,BackSpace to get the output code for the Backspace key... you
can use that in your inputrc to fix it... works for me with aterm
Reply | Threaded
Open this post in threaded view
|

Re: Backspace not working

James Vega-3
In reply to this post by Matthew.Hinman
On Wed, Jun 08, 2005 at 10:07:33AM -0600, [hidden email] wrote:
> I did something to mess up my vim config, backspace used to work just fine
> (delete the character to the left of the cursor). Now it doesn't do anything in
> insert mode.

You should:

a) Make sure you're not in compatible mode, ":set cp?" should say
nocompatible

b) Check your 'backspace' setting.  ":set bs=2" should allow you to
backspace normally in insert mode.


James
--
GPG Key: 1024D/61326D40 2003-09-02 James Vega <[hidden email]>

signature.asc (204 bytes) Download Attachment