Bugreport/Compile Issue >8.1.224 MacOSX, gui_mac.c undefined local symbol

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Bugreport/Compile Issue >8.1.224 MacOSX, gui_mac.c undefined local symbol

Nicholas Stallard-2
Hello,

I am unable to compile vim >8.1.224 as Vim.app on MacOSX.
The error I am getting is:

gui_mac.c: In function 'myDataBrowserChangeAttributes':
gui_mac.c:6615: warning: 'NSIsSymbolNameDefined' is deprecated (declared at
/Developer-old/SDKs/MacOSX10.6.sdk/usr/include/mach-o/dyld.h:176)
gui_mac.c:6616: warning: 'NSLookupAndBindSymbol' is deprecated (declared at
/Developer-old/SDKs/MacOSX10.6.sdk/usr/include/mach-o/dyld.h:179)
gui_mac.c:6619: warning: 'NSAddressOfSymbol' is deprecated (declared at
/Developer-old/SDKs/MacOSX10.6.sdk/usr/include/mach-o/dyld.h:188)
{standard input}:unknown:Undefined local symbol
L__DefaultRuneLocale$non_lazy_ptr
{standard input}:unknown:Undefined local symbol
L___stack_chk_guard$non_lazy_ptr
{standard input}:unknown:Undefined local symbol L_firstbuf$non_lazy_ptr
make[1]: *** [objects/gui_mac.o] Error 1
make: *** [first] Error 2


The last compiler command was this:

/Developer-old/usr/bin/gcc-4.2 -std=gnu99 -c -I.  -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MAC -fno-common -fpascal-strings -Wall -Wno-unknown-pragmas -mdynamic-no-pic -pipe -I. -Iproto -I/Developer-old/Headers/FlatCarbon -DMACOS_X -DMACOS_X_DARWIN -I/Developer-old/Headers/FlatCarbon  -isysroot /Developer-old/SDKs/MacOSX10.6.sdk       -arch i386 -mmacosx-version-min=10.6 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1        -o objects/gui_mac.o gui_mac.c

The compiler environent is:

export       CC="$DEVELOPER_DIR/usr/bin/gcc-4.2"
export   CFLAGS="-isysroot $DEVELOPER_DIR/SDKs/MacOSX10.6.sdk       -arch i386 -mmacosx-version-min=10.6"
export  LDFLAGS="-Wl,-syslibroot,$DEVELOPER_DIR/SDKs/MacOSX10.6.sdk -arch i386 -mmacosx-version-min=10.6"
export CPPFLAGS="-I$DEVELOPER_DIR/Headers/FlatCarbon"

ProductName: Mac OS X
ProductVersion: 10.7.5
BuildVersion: 11G63b

Checking the gui_mac.c file from the 8.1.224 to the most recent I can not see
that the changes have anything to do with the undefined local symbols.

How an I resolve the issue?

Kind regards, Nicholas


--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.