Combining accents in MacVim

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Combining accents in MacVim

Nicola
Hi,
sorry if this has been reported already (I could not find any information).

Combining accents are not rendered correctly in MacVim, no matter
whether "Draw marked text inline" is checked or not. Try, for example,
ė̃ (U+0303 with U+0117). Such combinations are displayed correctly in
terminal Vim (both in Terminal.app and iTerm2) using the same fonts (I
have tried with Menlo, Consolas, and SF Mono).

Using MacVim 7.4 (104), patch 1-1941, compiled by Homebrew.

Nicola



--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Combining accents in MacVim

Nicola
On 2016-06-27 07:37:22 +0000, Nicola said:

> Hi,
> sorry if this has been reported already (I could not find any information).
>
> Combining accents are not rendered correctly in MacVim, no matter
> whether "Draw marked text inline" is checked or not. Try, for example,
> ė̃ (U+0303 with U+0117). Such combinations are displayed correctly in
> terminal Vim (both in Terminal.app and iTerm2) using the same fonts (I
> have tried with Menlo, Consolas, and SF Mono).
>
> Using MacVim 7.4 (104), patch 1-1941, compiled by Homebrew.


Sorry, forgot to mention that this happens only when using the Core
Text renderer.

Nicola


--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Combining accents in MacVim

Tony Mechelynck
In reply to this post by Nicola
On Monday, June 27, 2016 at 9:37:42 AM UTC+2, Nicola wrote:

> Hi,
> sorry if this has been reported already (I could not find any information).
>
> Combining accents are not rendered correctly in MacVim, no matter
> whether "Draw marked text inline" is checked or not. Try, for example,
> ė̃ (U+0303 with U+0117). Such combinations are displayed correctly in
> terminal Vim (both in Terminal.app and iTerm2) using the same fonts (I
> have tried with Menlo, Consolas, and SF Mono).
>
> Using MacVim 7.4 (104), patch 1-1941, compiled by Homebrew.
>
> Nicola
No reply, it seems.

On Linux, I have noticed that some fonts place combining characters correctly while others don't. For instance in FreeMono (and FreeSans and FreeSerif in the browser) the combining accents are correctly placed. In some other fonts (I forget which) they aren't.


Best regards,
Tony.

--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Combining accents in MacVim

Nicola
On 2016-08-06 11:10:38 +0000, Tony Mechelynck said:

> On Monday, June 27, 2016 at 9:37:42 AM UTC+2, Nicola wrote:
>> Hi,
>> sorry if this has been reported already (I could not find any information).
>>
>> Combining accents are not rendered correctly in MacVim, no matter
>> whether "Draw marked text inline" is checked or not. Try, for example,
>> ė̃ (U+0303 with U+0117). Such combinations are displayed correctly in
>> terminal Vim (both in Terminal.app and iTerm2) using the same fonts (I
>> have tried with Menlo, Consolas, and SF Mono).
>>
>> Using MacVim 7.4 (104), patch 1-1941, compiled by Homebrew.
>>
>> Nicola
>
> No reply, it seems.
>
> On Linux, I have noticed that some fonts place combining characters
> correctly while others don't. For instance in FreeMono (and FreeSans
> and FreeSerif in the browser) the combining accents are correctly
> placed. In some other fonts (I forget which) they aren't.

I do not think that it is a font problem. I have tried with lots of
fonts (including FreeMono) and the behaviour is the same: using Core
Text Renderer, the height of diacritical marks does not adapt to the
height of the associated glyph.

Btw, is this the right place to report issues or should I use GitHub?

Nicola


--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Combining accents in MacVim

Tony Mechelynck
On Tuesday, August 9, 2016 at 6:50:52 PM UTC+2, Nicola wrote:

> On 2016-08-06 11:10:38 +0000, Tony Mechelynck said:
>
> > On Monday, June 27, 2016 at 9:37:42 AM UTC+2, Nicola wrote:
> >> Hi,
> >> sorry if this has been reported already (I could not find any information).
> >>
> >> Combining accents are not rendered correctly in MacVim, no matter
> >> whether "Draw marked text inline" is checked or not. Try, for example,
> >> ė̃ (U+0303 with U+0117). Such combinations are displayed correctly in
> >> terminal Vim (both in Terminal.app and iTerm2) using the same fonts (I
> >> have tried with Menlo, Consolas, and SF Mono).
> >>
> >> Using MacVim 7.4 (104), patch 1-1941, compiled by Homebrew.
> >>
> >> Nicola
> >
> > No reply, it seems.
> >
> > On Linux, I have noticed that some fonts place combining characters
> > correctly while others don't. For instance in FreeMono (and FreeSans
> > and FreeSerif in the browser) the combining accents are correctly
> > placed. In some other fonts (I forget which) they aren't.
>
> I do not think that it is a font problem. I have tried with lots of
> fonts (including FreeMono) and the behaviour is the same: using Core
> Text Renderer, the height of diacritical marks does not adapt to the
> height of the associated glyph.
>
> Btw, is this the right place to report issues or should I use GitHub?
>
> Nicola
If this is a mac-only issue, as it seems to be, this is the proper place.

For issues concerning all versions of Vim whether or not running on a Mac, there are also the vim_use Google group for questions about general use, for instance "How do I get syntax highlighting even on very long lines" or "what is the difference between vimrc and gvimrc? (both of these are answered in the help), and the vim_dev Google Group for "development" issues including bug reports, crash reports, requests for enhancements, etc.

GitHub issues are reflected on the vim_dev group.


Best regards,
Tony.

--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.