Compilation error

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Compilation error

aydar.kh
Trying to compile MacVim from source, but stuck on these error messages:

Undefined symbols for architecture x86_64:
  "_iconv", referenced from:
      _readfile in fileio.o
      _buf_write_bytes in fileio.o
      _my_iconv_open in mbyte.o
      _string_convert_ext in mbyte.o
     (maybe you meant: _my_iconv_open)
  "_iconv_close", referenced from:
      _readfile in fileio.o
      _buf_write in fileio.o
      _utf_find_illegal in mbyte.o
      _my_iconv_open in mbyte.o
      _convert_setup_ext in mbyte.o
  "_iconv_open", referenced from:
      _my_iconv_open in mbyte.o
     (maybe you meant: _my_iconv_open)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [Vim] Error 1
make: *** [first] Error 2

Full log of compilation http://pastebin.com/hjjEpurf

Any ideas?

--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Compilation error

aydar.kh
On Saturday, March 19, 2016 at 1:31:49 PM UTC+5, [hidden email] wrote:

> Trying to compile MacVim from source, but stuck on these error messages:
>
> Undefined symbols for architecture x86_64:
>   "_iconv", referenced from:
>       _readfile in fileio.o
>       _buf_write_bytes in fileio.o
>       _my_iconv_open in mbyte.o
>       _string_convert_ext in mbyte.o
>      (maybe you meant: _my_iconv_open)
>   "_iconv_close", referenced from:
>       _readfile in fileio.o
>       _buf_write in fileio.o
>       _utf_find_illegal in mbyte.o
>       _my_iconv_open in mbyte.o
>       _convert_setup_ext in mbyte.o
>   "_iconv_open", referenced from:
>       _my_iconv_open in mbyte.o
>      (maybe you meant: _my_iconv_open)
> ld: symbol(s) not found for architecture x86_64
> clang: error: linker command failed with exit code 1 (use -v to see invocation)
> make[1]: *** [Vim] Error 1
> make: *** [first] Error 2
>
> Full log of compilation http://pastebin.com/hjjEpurf
>
> Any ideas?
Ok, this article helped me https://blog.wwwjfy.net/2011/03/02/compile-vim-7-3-in-mac-os-x-10-6-6/

--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Loading...