Dead keys doesn't work in a terminal window in gvim

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Dead keys doesn't work in a terminal window in gvim

Cesar Romani-2
I'm using gvim 8.1.1140 on Windows 7 with US-International layout
keyboard.

Normally, when I use the command prompt cmd.exe, with code page 1252,
and press the ' key (dead key) and the "a" key I get "á", but on a
terminal window in gvim I get 'a.
The same happens with the keys "^" and "a". I should get "â", but I get
^a.

On neovim I don't have that problem, and I can get accented characters
using dead keys on a terminal.

Many thanks in advance,

--
Cesar

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Dead keys doesn't work in a terminal window in gvim

trialero
On Wed, Apr 10, 2019 at 02:51:45PM -0700, andalou wrote:
> I'm using gvim 8.1.1140 on Windows 7 with US-International layout
> keyboard.
>
> Normally, when I use the command prompt cmd.exe, with code page 1252,
> and press the ' key (dead key) and the "a" key I get "á", but on a
> terminal window in gvim I get 'a.
> The same happens with the keys "^" and "a". I should get "â", but I get
> ^a.

it depends on how the command prompt and terminal is activated. some
terminals don't display special characters, even when you set the
character set to it. probably neovim does it differently from cmd.exe
and gvim.

//meine

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.