Deleting non-empty directories in netrw in Vim 8+

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Deleting non-empty directories in netrw in Vim 8+

Trevor D. Miller
When using `D` on top of a non-empty directory in netrw I get an error: `**error** (netrw) unable to delete directory {path}`. `D` works as expected on an empty directory.

I've tried setting `let g:netrw_localrmdir='rm -rf'` (https://gist.github.com/KevinSjoberg/5068370) with the same result. Looking at the man page for `:help netrw_localrmdir` it says "This variable is only used if your vim is earlier than 7.4"

How can I use `D` to delete non-empty directories in Vim 8+?

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.