E474: Invalid argument: listchars=tab:?~V?\ ,eol:¬^[^[

classic Classic list List threaded Threaded
24 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: =?UTF-8?Q?E474:_Invalid_argument:_lis? =?UTF-8?Q?tchars=tab:?~V?\_,eol:¬^[^[?MIME-Version: 1.0

Peng Yu
On Sun, Jan 13, 2019 at 11:47 PM Peng Yu <[hidden email]> wrote:

>
> > You could also execute this in your docker container's shell:
> >
> >     $ locale -a
> >
> > and see if your language and UTF-8 encoding is supported.  If it is,
> > then just set LANG to that in your ~/.profile, or whatever the
> > preferred file du jour is for that sort of thing these days.
>
> This solves the problem. I think that it is the best solution to this problem.
>
> $ locale -a
> C
> C.UTF-8
> POSIX
> e000c0cf8d77:pts@05:44:49@~$ export LANG=C.UTF-8
> e000c0cf8d77:pts@05:44:57@~$ vim ~/.vimrc

But this does not fix this docker image.
(`~/docker_common/pkg/bin/vim` was compiled in the ubuntu docker
container.)

$ docker run -it --rm -v ~/docker_common/pkg:/pkg publicisworldwide/python-conda
[lion@7e85e380877d /]$ /pkg/bin/vim
[lion@7e85e380877d /]$ locale -a |grep -i utf
en_AG.utf8
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN.utf8
en_NG.utf8
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZM.utf8
en_ZW.utf8
[lion@7e85e380877d /]$ export LANG=en_US.utf8
[lion@7e85e380877d /]$ /pkg/bin/vim

`set encoding` still gives `latin1`. What is wrong with this docker image?

--
Regards,
Peng

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: =?UTF-8?Q?E474:_Invalid_argument:_lis? =?UTF-8?Q?tchars=tab:?~V?\_,eol:¬^[^[?MIME-Version: 1.0

Tony Mechelynck
On Mon, Jan 14, 2019 at 7:05 AM Peng Yu <[hidden email]> wrote:

>
> On Sun, Jan 13, 2019 at 11:47 PM Peng Yu <[hidden email]> wrote:
> >
> > > You could also execute this in your docker container's shell:
> > >
> > >     $ locale -a
> > >
> > > and see if your language and UTF-8 encoding is supported.  If it is,
> > > then just set LANG to that in your ~/.profile, or whatever the
> > > preferred file du jour is for that sort of thing these days.
> >
> > This solves the problem. I think that it is the best solution to this problem.
> >
> > $ locale -a
> > C
> > C.UTF-8
> > POSIX
> > e000c0cf8d77:pts@05:44:49@~$ export LANG=C.UTF-8
> > e000c0cf8d77:pts@05:44:57@~$ vim ~/.vimrc
>
> But this does not fix this docker image.
> (`~/docker_common/pkg/bin/vim` was compiled in the ubuntu docker
> container.)
>
> $ docker run -it --rm -v ~/docker_common/pkg:/pkg publicisworldwide/python-conda
> [lion@7e85e380877d /]$ /pkg/bin/vim
> [lion@7e85e380877d /]$ locale -a |grep -i utf
> en_AG.utf8
> en_AU.utf8
> en_BW.utf8
> en_CA.utf8
> en_DK.utf8
> en_GB.utf8
> en_HK.utf8
> en_IE.utf8
> en_IN.utf8
> en_NG.utf8
> en_NZ.utf8
> en_PH.utf8
> en_SG.utf8
> en_US.utf8
> en_ZA.utf8
> en_ZM.utf8
> en_ZW.utf8
> [lion@7e85e380877d /]$ export LANG=en_US.utf8
> [lion@7e85e380877d /]$ /pkg/bin/vim
>
> `set encoding` still gives `latin1`. What is wrong with this docker image?

Try
$ /pkg/bin/vim --version
in the docker image. Does it say +multi_byte or -multi_byte?

Best regards,
Tony.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: =?UTF-8?Q?E474:_Invalid_argument:_lis? =?UTF-8?Q?tchars=tab:?~V?\_,eol:¬^[^[?MIME-Version: 1.0

Peng Yu
Again, it is not the problem of vim binary. The same binary works in the ubuntu docker container.

On Mon, Jan 14, 2019 at 12:15 AM Tony Mechelynck <[hidden email]> wrote:
On Mon, Jan 14, 2019 at 7:05 AM Peng Yu <[hidden email]> wrote:
>
> On Sun, Jan 13, 2019 at 11:47 PM Peng Yu <[hidden email]> wrote:
> >
> > > You could also execute this in your docker container's shell:
> > >
> > >     $ locale -a
> > >
> > > and see if your language and UTF-8 encoding is supported.  If it is,
> > > then just set LANG to that in your ~/.profile, or whatever the
> > > preferred file du jour is for that sort of thing these days.
> >
> > This solves the problem. I think that it is the best solution to this problem.
> >
> > $ locale -a
> > C
> > C.UTF-8
> > POSIX
> > e000c0cf8d77:pts@05:44:49@~$ export LANG=C.UTF-8
> > e000c0cf8d77:pts@05:44:57@~$ vim ~/.vimrc
>
> But this does not fix this docker image.
> (`~/docker_common/pkg/bin/vim` was compiled in the ubuntu docker
> container.)
>
> $ docker run -it --rm -v ~/docker_common/pkg:/pkg publicisworldwide/python-conda
> [lion@7e85e380877d /]$ /pkg/bin/vim
> [lion@7e85e380877d /]$ locale -a |grep -i utf
> en_AG.utf8
> en_AU.utf8
> en_BW.utf8
> en_CA.utf8
> en_DK.utf8
> en_GB.utf8
> en_HK.utf8
> en_IE.utf8
> en_IN.utf8
> en_NG.utf8
> en_NZ.utf8
> en_PH.utf8
> en_SG.utf8
> en_US.utf8
> en_ZA.utf8
> en_ZM.utf8
> en_ZW.utf8
> [lion@7e85e380877d /]$ export LANG=en_US.utf8
> [lion@7e85e380877d /]$ /pkg/bin/vim
>
> `set encoding` still gives `latin1`. What is wrong with this docker image?

Try
$ /pkg/bin/vim --version
in the docker image. Does it say +multi_byte or -multi_byte?

Best regards,
Tony.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/YyON64D7Zec/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
--
Regards,
Peng

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: =?UTF-8?Q?E474:_Invalid_argument:_lis? =?UTF-8?Q?tchars=tab:?~V?\_,eol:¬^[^[?MIME-Version: 1.0

Benjamin Fritz
Check the output of ":verbose set encoding?"

That should tell you where the option was last set.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
12