Execute command problem with Easyalign

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Execute command problem with Easyalign

philip_rhoades
People,

I have F8 setup like this:

   nnoremap <F8> :Execute<CR>

which works for everything else but occasionally when I try to use it on
this line:

   :6,$EasyAlign |

I sometimes get an error like:

   "| not a delimiter key"

but other times it works fine - it is driving me crazy why it works
sometimes and not others . . any suggestions for debugging?

Thanks,

Phil.
--
Philip Rhoades

PO Box 896
Cowra  NSW  2794
Australia
E-mail:  [hidden email]

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Execute command problem with Easyalign

Ben Fritz
EasyAlign must not be set up to allow stringing it together with other commands using |. Probably because you might want to align | at some point.

To get past this, use the "execute" command, e.g.:

:execute "6,$EasyAlign" | whatever you wanted to come next

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Execute command problem with Easyalign

philip_rhoades
Ben,


On 2017-11-19 05:21, Ben Fritz wrote:
> EasyAlign must not be set up to allow stringing it together with other
> commands using |. Probably because you might want to align | at some
> point.
>
> To get past this, use the "execute" command, e.g.:
>
> :execute "6,$EasyAlign" | whatever you wanted to come next


You misunderstand - I DO want to use the "|" to align with - what I want
to know is WHY it works sometimes but not other times - and then I get
an error message like "| not a delimiter key" . .

Thanks,

Phil.
--
Philip Rhoades

PO Box 896
Cowra  NSW  2794
Australia
E-mail:  [hidden email]

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.