Macvim fails to load Netrw module when started off a session

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Macvim fails to load Netrw module when started off a session

thomas.nalevajko
Hi guys,

Thanks for hard work of all those making vimers comfortable and productive on OSX platform. I have switched to mac and found the following bug hampering productivity!

When macvim is opened with parameter -S that means to start off of the previously created session then it doesn't recognize netrw functions. That means, during the work with Vim if I execute ':Vexplore' vim responds with 'Unknown function: netrw#Explore'.

If I start macvim without -S argument then ':Vexplore' or ':e .' opens netrw explorer.



Steps to reproduce the bug:

1) Open macvim.
$ macvim

2) Create session.
:mks session.vis

3) Exit vim.

4) Startup macvim from the previously created session.
$ macvim -S session.vis

5) Execute
:Vexplore
Vim outputs 'Unknown function: netrw#Explore'


To see the expected behavior follow these steps:

1) Open macvim.
$ macvim

2) Execute
:Vexplore
Explorer window is opened.


Can others reproduce the bug, find out and fix its cause?

Best, Thomas

--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Macvim fails to load Netrw module when started off a session

Nicola
On 2016-05-05 10:13:56 +0000,
[hidden email] said:

> Hi guys,
>
> Thanks for hard work of all those making vimers comfortable and
> productive on OSX platform. I have switched to mac and found the
> following bug hampering productivity!
>
> When macvim is opened with parameter -S that means to start off of the
> previously created session then it doesn't recognize netrw functions.
> That means, during the work with Vim if I execute ':Vexplore' vim
> responds with 'Unknown function: netrw#Explore'.
>
> If I start macvim without -S argument then ':Vexplore' or ':e .' opens
> netrw explorer.
>
> Can others reproduce the bug, find out and fix its cause?

I've tried your steps, but it works for me. Using MacVim 7.4-102,
installed with `brew macvim --HEAD`.

Nicola


--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Macvim fails to load Netrw module when started off a session

thomas.nalevajko
Thanks. I see if I remove .vimrc then it doesn't happen. The culprit is going to be one of the plugins. I will test them one by one :( It doesn't happen with gvim on other Linux platform.

VIM - Vi IMproved 7.4 (2013 Aug 10, compiled May  4 2016 17:30:35)
MacOS X (unix) version
Included patches: 1-1816
Compiled by [hidden email]

7.4-103 now, was 7.4-102.

Thomas

On Thursday, May 5, 2016 at 9:48:09 PM UTC+1, Nicola wrote:

> On 2016-05-05 10:13:56 +0000,
> [hidden email] said:
>
> > Hi guys,
> >
> > Thanks for hard work of all those making vimers comfortable and
> > productive on OSX platform. I have switched to mac and found the
> > following bug hampering productivity!
> >
> > When macvim is opened with parameter -S that means to start off of the
> > previously created session then it doesn't recognize netrw functions.
> > That means, during the work with Vim if I execute ':Vexplore' vim
> > responds with 'Unknown function: netrw#Explore'.
> >
> > If I start macvim without -S argument then ':Vexplore' or ':e .' opens
> > netrw explorer.
> >
> > Can others reproduce the bug, find out and fix its cause?
>
> I've tried your steps, but it works for me. Using MacVim 7.4-102,
> installed with `brew macvim --HEAD`.
>
> Nicola
--
--
You received this message from the "vim_mac" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_mac" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.