Possible error in instructions for manual installation?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Possible error in instructions for manual installation?

Carlo Trimarchi
Hi,
I'm new here.

Today I've installed vimoutliner on Ubuntu 7.10. I downloaded the
sources from here: http://packages.debian.org/etch/vim-vimoutliner

As I have a compiled version of vim and not the one on repositories, I
followed the steps for the manual installation. I just moved files in
the right place and then I tried to test Vimoutliner with a
vo_test.otl file. It didn't work.

To make it work I typed :setfiletype vo_base and it coloured the lines
in different indentation levels. So it seemed it did not recognize the
filetype.

Searching around I read to put this line:

runtime! ftdetect/*.vim

inside ~/.vim/filetype.vim, instead of ~/.vim/ftplugin/vo_base.vim, as
it said in the instructions. This actually worked.

Is that an error in the instructions or did I do something wrong?
_______________________________________________
VimOutliner mailing list
[hidden email]
http://www.lists.vimoutliner.org/mailman/listinfo/vimoutliner
Reply | Threaded
Open this post in threaded view
|

Re: Possible error in instructions for manual installation?

Ross Boylan
On Thu, 2008-11-27 at 19:06 +0100, Mr.SpOOn wrote:

> Hi,
> I'm new here.
>
> Today I've installed vimoutliner on Ubuntu 7.10. I downloaded the
> sources from here: http://packages.debian.org/etch/vim-vimoutliner
>
> As I have a compiled version of vim and not the one on repositories, I
> followed the steps for the manual installation. I just moved files in
> the right place and then I tried to test Vimoutliner with a
> vo_test.otl file. It didn't work.
>
> To make it work I typed :setfiletype vo_base and it coloured the lines
> in different indentation levels. So it seemed it did not recognize the
> filetype.
>
> Searching around I read to put this line:
>
> runtime! ftdetect/*.vim
>
> inside ~/.vim/filetype.vim, instead of ~/.vim/ftplugin/vo_base.vim, as
> it said in the instructions. This actually worked.
>
> Is that an error in the instructions or did I do something wrong?
On Debian and derived systems plugins need to be activated manually.
See /usr/share/doc/vim/NEWS.Debian.gz for the details.  Install the
vim-addon-manager pack and see man vim-addons.
Ross Boylan
> _______________________________________________
> VimOutliner mailing list
> [hidden email]
> http://www.lists.vimoutliner.org/mailman/listinfo/vimoutliner

_______________________________________________
VimOutliner mailing list
[hidden email]
http://www.lists.vimoutliner.org/mailman/listinfo/vimoutliner