Re: suggest: Ruby 1.9 in VIM 7.3 by default

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: suggest: Ruby 1.9 in VIM 7.3 by default

George V. Reilly
On Wed, Jun 9, 2010 at 2:29 AM, Ciss <[hidden email]> wrote:
> I think what i can't create new thread in vim dev channel.
> Please, maybe anyone transfer my suggest to vim developers?

Perhaps you're not a member of the vim_dev group?
I tried building Vim with Ruby 1.9 on Windows a few weeks ago. Unlike
Ruby 1.8, it simply wasn't possible with the MSVC compiler, because
1.9 came with include files and libs for MinGW only.
Vim can be built with either MSVC or MinGW, but the official Windows
builds have always been built with MSVC.
It'd certainly be nice to have Ruby 1.9 be the default.
--
/George V. Reilly  [hidden email]  Twitter: @georgevreilly
http://www.georgevreilly.com/blog  http://blogs.cozi.com/tech

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
Reply | Threaded
Open this post in threaded view
|

Re: suggest: Ruby 1.9 in VIM 7.3 by default

Ciss
Thank's a lot for reposting.

Also i want add some comment.

I want to add some additional features into vim.
and i want to do this with ruby support.

ruby 1.8 is not so fast. But 1.9 version has some cool improve about
speed issue. (5x faster)

it will be great - to have native Ruby1.9 support.

Sorry for english, i'm from Russia.

On 9 июн, 09:28, "George V. Reilly" <[hidden email]> wrote:

> On Wed, Jun 9, 2010 at 2:29 AM, Ciss <[hidden email]> wrote:
> > I think what i can't create new thread in vim dev channel.
> > Please, maybe anyone transfer my suggest to vim developers?
>
> Perhaps you're not a member of the vim_dev group?
> I tried building Vim with Ruby 1.9 on Windows a few weeks ago. Unlike
> Ruby 1.8, it simply wasn't possible with the MSVC compiler, because
> 1.9 came with include files and libs for MinGW only.
> Vim can be built with either MSVC or MinGW, but the official Windows
> builds have always been built with MSVC.
> It'd certainly be nice to have Ruby 1.9 be the default.
> --
> /George V. Reilly  [hidden email]  Twitter: @georgevreillyhttp://www.georgevreilly.com/blog http://blogs.cozi.com/tech

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
Reply | Threaded
Open this post in threaded view
|

Re: suggest: Ruby 1.9 in VIM 7.3 by default

Ciss
Why no responce? =(

Ciss:

> Thank's a lot for reposting.
>
> Also i want add some comment.
>
> I want to add some additional features into vim.
> and i want to do this with ruby support.
>
> ruby 1.8 is not so fast. But 1.9 version has some cool improve about
> speed issue. (5x faster)
>
> it will be great - to have native Ruby1.9 support.
>
> Sorry for english, i'm from Russia.
>
> On 9 июн, 09:28, "George V. Reilly" <[hidden email]> wrote:
> > On Wed, Jun 9, 2010 at 2:29 AM, Ciss <[hidden email]> wrote:
> > > I think what i can't create new thread in vim dev channel.
> > > Please, maybe anyone transfer my suggest to vim developers?
> >
> > Perhaps you're not a member of the vim_dev group?
> > I tried building Vim with Ruby 1.9 on Windows a few weeks ago. Unlike
> > Ruby 1.8, it simply wasn't possible with the MSVC compiler, because
> > 1.9 came with include files and libs for MinGW only.
> > Vim can be built with either MSVC or MinGW, but the official Windows
> > builds have always been built with MSVC.
> > It'd certainly be nice to have Ruby 1.9 be the default.
> > --
> > /George V. Reilly  [hidden email]  Twitter: @georgevreillyhttp://www.georgevreilly.com/blog http://blogs.cozi.com/tech

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php