Setting the language

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Setting the language

Wiere Neuer
How would I set the language to en_US.UTF-8 via the "language" command in Windows gvim?

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/c99d6fc8-7599-42db-ab9e-01678594a06d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Setting the language

Christian Brabandt

On So, 19 Mai 2019, Axel Bender wrote:

> How would I set the language to en_US.UTF-8 via the "language" command
> in Windows gvim?

I am not sure why you want UTF-8 in Windows, it seems the more widely
used codepage in use is 1252 (for western countries).
UTF-8 Codepage in Windows is 65001, however it seems like setting that
via the language command does not work, at least not on my system here:

So try:

lang English_USA.1252
lang mes English_US.1252

Or don't explicitly care about the encoding and use
:lang English_USA
:lang mes English_USA


Best,
Christian
--
Wähl dir eine, der du sagst: Du nur gefällst mir allein.
                -- Ovid (43 v.Chr.-18 n.Chr) (Liebeskunst)

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/20190520055747.GK2769%40256bit.org.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Setting the language

Wiere Neuer
In reply to this post by Wiere Neuer
@Christian,

Thanks for your reply.

Is there any reason why anyone would not want UTF8? (just joking...)

That's exactly the problem, I can't set the language to UTF-8 for the various types (messages, ctype, time) in Windows.

language english_United States.1252 works (but is not what I want).
language english_United States.65001 (which represents UTF-8 in Windows) doesn't (as does english_United States.UTF-8 or english.United States.utf8), which all result in E197 being thrown.

I see no other way to influence the collation for sorting regions, e.g. with
'<,'>sort than setting the language...

I explicitly do not want Windows 1252.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/86e5ad8d-f847-4931-bfcd-98fa5dac08eb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Setting the language

Ken Takata-2
Hi,

2019/5/20 Mon 15:52:09 UTC+9 Axel Bender wrote:

> @Christian,
>
> Thanks for your reply.
>
> Is there any reason why anyone would not want UTF8? (just joking...)
>
> That's exactly the problem, I can't set the language to UTF-8 for the various types (messages, ctype, time) in Windows.
>
> language english_United States.1252 works (but is not what I want).
> language english_United States.65001 (which represents UTF-8 in Windows) doesn't (as does english_United States.UTF-8 or english.United States.utf8), which all result in E197 being thrown.
>
> I see no other way to influence the collation for sorting regions, e.g. with
> '<,'>sort than setting the language...
>
> I explicitly do not want Windows 1252.
If you want to use UTF-8, write the following line in your .vimrc (_vimrc):

    set encoding=utf-8

:language cannot be used for setting the encoding.

Regards,
Ken Takata

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/96470c80-bd2f-4cff-b355-23099516afb8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Setting the language

Wiere Neuer
@Ken

Thanks for the reply.

set encoding=utf-8 is my default setting...

However, in Windows:
- how can I influence the values of v:lc_time, v:lang, and v:ctype?
- how can I influence the way the internal sort command sorts (in Linux - having set $LC_ALL to "de_DE.UTF-8") sorting works with /bin/sort.

Questions over questions... ;-)

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/2bed98bc-4d07-4074-bdc2-27677a3b1b93%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Setting the language

Ken Takata-2
Hi,

2019/5/20 Mon 18:16:49 UTC+9 Axel Bender wrote:

> @Ken
>
> Thanks for the reply.
>
> set encoding=utf-8 is my default setting...
>
> However, in Windows:
> - how can I influence the values of v:lc_time, v:lang, and v:ctype?
> - how can I influence the way the internal sort command sorts (in Linux - having set $LC_ALL to "de_DE.UTF-8") sorting works with /bin/sort.
>
> Questions over questions... ;-)
The internal sort doesn't affected by the locale.

Regards,
Ken Takata

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/cd6f1d9f-0263-48ad-b7a3-919d0f959229%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.