Spell checking not working correctly for me

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Spell checking not working correctly for me

Niels Kobschaetzki
Hi,

yesterday I tried in a long time the spell checking feature. Besides a strange German dictionary “z=“ does not work for me. When I hit z= the cursor jumps to the beginning of the line. ctrl+x s works though for getting spelling suggestions. Any ideas how I can figure out what the reason for that behavior is?

Also it can take ages to show suggestions when I have longer words. Is that normal behavior?

Best

Niels

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/A93F3890-F1BC-45DA-8A80-8BB355A1A4AE%40kobschaetzki.net.
Reply | Threaded
Open this post in threaded view
|

Re: Spell checking not working correctly for me

Paul-7
On Wed, Sep 16, 2020 at 06:08:38AM +0200, Niels Kobschätzki wrote:
>yesterday I tried in a long time the spell checking feature. Besides a strange German dictionary “z=“ does not work for me. When I hit z= the cursor jumps to the beginning of the line. ctrl+x s works though for getting spelling suggestions. Any ideas how I can figure out what the reason for that behavior is?

Try ":verbose nmap z" to see if you have any mappings that start with "z".

>Also it can take ages to show suggestions when I have longer words. Is that normal behavior?

No.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/20200920174231.GA31700%40rainslide.net.

signature.asc (817 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Spell checking not working correctly for me

Christian Brabandt
In reply to this post by Niels Kobschaetzki

On Mi, 16 Sep 2020, Niels Kobschätzki wrote:

> Hi,
>
> yesterday I tried in a long time the spell checking feature. Besides a
> strange German dictionary “z=“ does not work for me. When I hit z= the
> cursor jumps to the beginning of the line. ctrl+x s works though for
> getting spelling suggestions. Any ideas how I can figure out what the
> reason for that behavior is?
>
> Also it can take ages to show suggestions when I have longer words. Is
> that normal behavior?

Looks like a regression caused by using different dictionary.

https://github.com/vim/vim/issues/6972
https://github.com/vim/vim/issues/6963#issuecomment-693483158

Best,
Christian
--
Alles ist klar und keiner weiß Bescheid.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/20200921091121.GA1002%40256bit.org.
Reply | Threaded
Open this post in threaded view
|

Re: Spell checking not working correctly for me

Niels Kobschaetzki
In reply to this post by Paul-7
On 20 Sep 2020, at 19:42, Paul wrote:

> On Wed, Sep 16, 2020 at 06:08:38AM +0200, Niels Kobschätzki wrote:
>> yesterday I tried in a long time the spell checking feature. Besides
>> a strange German dictionary “z=“ does not work for me. When I hit
>> z= the cursor jumps to the beginning of the line. ctrl+x s works
>> though for getting spelling suggestions. Any ideas how I can figure
>> out what the reason for that behavior is?
>
> Try ":verbose nmap z" to see if you have any mappings that start with
> "z".

No mapping found

Niels

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/F9AC2FFA-6D3E-4DCB-887A-C350124F142E%40kobschaetzki.net.
Reply | Threaded
Open this post in threaded view
|

Re: Spell checking not working correctly for me

Niels Kobschaetzki
In reply to this post by Christian Brabandt
On 21 Sep 2020, at 11:11, Christian Brabandt wrote:

> On Mi, 16 Sep 2020, Niels Kobschätzki wrote:
>
>> Hi,
>>
>> yesterday I tried in a long time the spell checking feature. Besides a
>> strange German dictionary “z=“ does not work for me. When I hit z= the
>> cursor jumps to the beginning of the line. ctrl+x s works though for
>> getting spelling suggestions. Any ideas how I can figure out what the
>> reason for that behavior is?
>>
>> Also it can take ages to show suggestions when I have longer words. Is
>> that normal behavior?
>
> Looks like a regression caused by using different dictionary.
>
> https://github.com/vim/vim/issues/6972
> https://github.com/vim/vim/issues/6963#issuecomment-693483158

Thanks.

Best,

Niels

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vim_use/5CDBE435-6DD6-41A9-A2DD-9D68149151F1%40kobschaetzki.net.