Starting Neovim: notedown executable is required in order for this software to work. ...

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Starting Neovim: notedown executable is required in order for this software to work. ...

tasmo
Hi everyone,

When starting Neovim in a Terminal, it gives out:

```
notedown executable is required in order for this software to work. Check whether you have needed dependencies installed in README.md

```

Also the permissions by ``` :w ``` don't work proper.
Ether I have to force with ``` :w! ``` ,or even nothing works.

I run Neovim 0.3.4 lubuntu_18.0.2_bionic. But I tried also Neovim 2.0.0 already, with the same problem.

I read the README.md on https://github.com/neovim/neovim. Or which README.md could by ment? Whithout getting any hint.

I don't understand, and can't find anything about a
»notedown executable«.

So far my problem with Neovim.


THANKS

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Starting Neovim: notedown executable is required in order for this software to work. ...

Christian Brabandt
Hi,
I am not sure, if you are not off topic here with Neovim problems.
Nevertheless I try to give you some hints.

On Di, 26 Mär 2019, Jo Tasmo wrote:

> When starting Neovim in a Terminal, it gives out:
>
> ```
> notedown executable is required in order for this software to work. Check whether you have needed dependencies installed in README.md

Have you installed any external plugins that requires notedown?
Could it be this:
https://github.com/szymonmaszke/vimpyter

Note it requires notedown to be installed:
https://github.com/aaren/notedown

> Also the permissions by ``` :w ``` don't work proper.
> Ether I have to force with ``` :w! ``` ,or even nothing works.

Not sure what you mean with doesn't work.
I suspect this should be filed with more details at:
https://github.com/neovim/neovim/issues/

Please be more verbose when filing a bug:
Do you get an error message? What exactly do you expect the permissions
to be? How to reproduce this?

Best,
Christian
--
Tätig ist man immer mit einen gewissen Lärm. Wirken geht in der Stille
vor sich.
                -- Peter Bamm

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Starting Neovim: notedown executable is required in order for this software to work. ...

tasmo
... for being out of topic, the answer came quick, and solved the problem.

😇👍

Thanks very much. 

Christian Brabandt <[hidden email]> schrieb am Di., 26. März 2019, 10:10:
Hi,
I am not sure, if you are not off topic here with Neovim problems.
Nevertheless I try to give you some hints.

On Di, 26 Mär 2019, Jo Tasmo wrote:

> When starting Neovim in a Terminal, it gives out:
>
> ```
> notedown executable is required in order for this software to work. Check whether you have needed dependencies installed in README.md

Have you installed any external plugins that requires notedown?
Could it be this:
https://github.com/szymonmaszke/vimpyter

Note it requires notedown to be installed:
https://github.com/aaren/notedown

> Also the permissions by ``` :w ``` don't work proper.
> Ether I have to force with ``` :w! ``` ,or even nothing works.

Not sure what you mean with doesn't work.
I suspect this should be filed with more details at:
https://github.com/neovim/neovim/issues/

Please be more verbose when filing a bug:
Do you get an error message? What exactly do you expect the permissions
to be? How to reproduce this?

Best,
Christian
--
Tätig ist man immer mit einen gewissen Lärm. Wirken geht in der Stille
vor sich.
                -- Peter Bamm

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/C7WYnGk2p70/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.