Quantcast

Weird rendering issues after grepping some text

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Weird rendering issues after grepping some text

vram.v.s
In my .vimrc I have the line below, that I use for grepping for word under the cursor:

command! -nargs=+ Grp execute 'grep! -I -r -n --include=*.h --include=*.hpp --include=*.inl --include=*.cpp --include=*.c . -e <args>' | copen | execute 'silent /<args>'

Every time I run this command most part of the code disappears, and to see it I have to scroll down/up until the damaged regions are re-rendered.
Any ideas how to fix this?

Many thanks in advance!
PS. I'm not a vim guru, the command above was copy-pasted ;)

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Weird rendering issues after grepping some text

Jostein Berntsen
On 08.03.17,09:53, [hidden email] wrote:

>In my .vimrc I have the line below, that I use for grepping for word under the cursor:
>
>command! -nargs=+ Grp execute 'grep! -I -r -n --include=*.h --include=*.hpp --include=*.inl --include=*.cpp --include=*.c . -e <args>' | copen | execute 'silent /<args>'
>
>Every time I run this command most part of the code disappears, and to see it I have to scroll down/up until the damaged regions are re-rendered.
>Any ideas how to fix this?
>
>Many thanks in advance!
>PS. I'm not a vim guru, the command above was copy-pasted ;)
>

Can you check if adding a redraw command after execute works?

:redr!<cr>


Jostein

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Weird rendering issues after grepping some text

vram.v.s
On Wednesday, 8 March 2017 21:36:59 UTC+1, jostber  wrote:

> On 08.03.17,09:53, [hidden email] wrote:
> >In my .vimrc I have the line below, that I use for grepping for word under the cursor:
> >
> >command! -nargs=+ Grp execute 'grep! -I -r -n --include=*.h --include=*.hpp --include=*.inl --include=*.cpp --include=*.c . -e <args>' | copen | execute 'silent /<args>'
> >
> >Every time I run this command most part of the code disappears, and to see it I have to scroll down/up until the damaged regions are re-rendered.
> >Any ideas how to fix this?
> >
> >Many thanks in advance!
> >PS. I'm not a vim guru, the command above was copy-pasted ;)
> >
>
> Can you check if adding a redraw command after execute works?
>
> :redr!<cr>
>
>
> Jostein
That's solved the problem, finally!
Thanks a lot! :)

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Loading...