bufexists fails on bufname value '__Explorer__.1'

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

bufexists fails on bufname value '__Explorer__.1'

Ni Va
Hi,

On a named buffer '__Explorer__.1', is that normal the function bufexists(bufname("%")) returns 0 ?

Thank you
NiVa

echo bufname("%").' exists ? '. bufexists(bufname("%"))

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

vim.gif (47K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: bufexists fails on bufname value '__Explorer__.1'

Ni Va
Le mercredi 12 décembre 2018 18:36:02 UTC+1, Ni Va a écrit :
> Hi,
>
> On a named buffer '__Explorer__.1', is that normal the function bufexists(bufname("%")) returns 0 ?
>
> Thank you
> NiVa
>
> echo bufname("%").' exists ? '. bufexists(bufname("%"))

Ok have to set buftype=nofile.

Sorry.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.