canna/kinput disconnects

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

canna/kinput disconnects

K.P.Boomsma
Ever since I've tried to use GTK2 gvim (6.3) with utf-8 and
canna/kinput2 kinput2 dies when I do one of two things:

insert mode: start kinput2, type something, open selection window
with space, move in the selection screen with space or arrow, then
1. using backspace disconnects from kinput2
2. using enter once or twice (confirm selection) often disconnects
from kinput2

The latter is impossible to avoid when typing homonyms, so I've been
using scim for the last 6 months, but I miss some of the features of
kinput2. Other versions of gvim (GTK1, Athena) dont't have this problem,
(but don't support utf-8 that well) nor have other programs this
problem with my kinput2. It isn't anything in my .gvimrc either.
I'm running Linux 2.4.26 X Release 6.7 (Slackware 10). I've tried vim63b
as well.

Any help is appreciated.

Kornelis



ps currently I'm using the version that comes with Slackware 10.0,
but compiling my own version (--with-features=big in a GTK2 env)
made no difference. I've tested with an empty .gvimrc as well.




VIM - Vi IMproved 6.3 (2004 June 7, compiled Jun 13 2004 12:57:39)
Included patches: 1-4
Compiled by root@midas
Big version with GTK2 GUI.  Features included (+) or not (-):
+arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard
+cmdline_compl +cmdline_hist +cmdline_info +comments +cryptv +cscope +dialog_con_gui +diff +digraphs
+dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +folding
-footer +fork() -gettext -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
+linebreak +lispindent +listcmds +localmap +menu +mksession +modify_fname +mouse +mouseshape +mouse_dec
  +mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_xterm +multi_byte +multi_lang +netbeans_intg
-osfiletype +path_extra -perl +postscript +printer -python +quickfix +rightleft -ruby +scrollbind
+signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white
  -tcl +terminfo +termresponse +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
+visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim
  +xsmp_interact +xterm_clipboard -xterm_save
    system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
       user exrc file: "$HOME/.exrc"
   system gvimrc file: "$VIM/gvimrc"
     user gvimrc file: "$HOME/.gvimrc"
     system menu file: "$VIMRUNTIME/menu.vim"
   fall-back for $VIM: "/usr/share/vim"
Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.
0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -O2  -I/usr/X11R6/include
Linking: gcc  -L/usr/X11R6/lib   -L/usr/local/lib -o vim   -Wl,--export-dynamic -lgtk-x11-2.0 -lgdk-x11-
2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -
lglib-2.0   -lXt -lncurses -lgpm











--
* http://promulgate.xs4all.nl