. character not repeating last editor command in one case

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

. character not repeating last editor command in one case

madiyaan-3

Hello:

When editing C files (.h or .cpp files), if I type something like:

()<cr><esc>

And go somewhere else and press dot in normal mode, it does not put in
both parentheses. Instead it only puts in the closing paren. Is this a
problem with any script that I am using? Has anyone seen this problem
before?

This problem doesn't happen when editing regular files for some
reason.

Thanks,
--~--~---------~--~----~------------~-------~--~----~
You received this message from the "vim_use" maillist.
For more information, visit http://www.vim.org/maillist.php
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: . character not repeating last editor command in one case

madiyaan-3

Okay, I isolated this problem to this script:

http://www.vim.org/scripts/script.php?script_id=1735

Does anyone know how to fix this script so it doesn't affect dot
functionality? Basically whenever I type (bla bla bla) and press dot
in normal mode, it considers the last change made as only the closing
paren (and not opening paren with bla bla bla).

Thanks,

On Apr 30, 2:38 pm, madiyaan <[hidden email]> wrote:

> Hello:
>
> When editing C files (.h or .cpp files), if I type something like:
>
> ()<cr><esc>
>
> And go somewhere else and press dot in normal mode, it does not put in
> both parentheses. Instead it only puts in the closing paren. Is this a
> problem with any script that I am using? Has anyone seen this problem
> before?
>
> This problem doesn't happen when editing regular files for some
> reason.
>
> Thanks,
--~--~---------~--~----~------------~-------~--~----~
You received this message from the "vim_use" maillist.
For more information, visit http://www.vim.org/maillist.php
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: . character not repeating last editor command in one case

David Fishburn-2

On Thu, Apr 30, 2009 at 5:41 PM, madiyaan <[hidden email]> wrote:
>
> Okay, I isolated this problem to this script:
>
> http://www.vim.org/scripts/script.php?script_id=1735

Instead of just posting the link (which most people will be unwilling
to click on) also post the title of the plugin:
echofunc.vim : Echo the function declaration in the command line for C/C++.

That way, people might recognize it, or at least the author of the
plugin might check your email.

With just the URL, I image most people will bypass your email.

Dave

--~--~---------~--~----~------------~-------~--~----~
You received this message from the "vim_use" maillist.
For more information, visit http://www.vim.org/maillist.php
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: . character not repeating last editor command in one case

iler.ml
In reply to this post by madiyaan-3

On May 1, 12:41 am, madiyaan <[hidden email]> wrote:
> Okay, I isolated this problem to this script:
>
> http://www.vim.org/scripts/script.php?script_id=1735
>

Notify author of the plugin.

--~--~---------~--~----~------------~-------~--~----~
You received this message from the "vim_use" maillist.
For more information, visit http://www.vim.org/maillist.php
-~----------~----~----~----~------~----~------~--~---