command-t plugin need wrong ruby version

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

command-t plugin need wrong ruby version

Sand Glass
I want to install command-t plugin.(gvim 7.4; windows)
https://github.com/wincent/command-t
It needs ruby 1.9.2. I download the right ruby version.
http://rubyinstaller.org/downloads/archives
But when I run ':ruby 1' to test ruby. It shows Error "E370  msvcrt-ruby192.dll
 lost", then I goto the ruby diretory to search the 192.dll, but only msvcrt-ruby191.dll, I tried all 192 ruby verion in above page. All of them 191.dll, I tried to change msvcrt-ruby191.dll to msvcrt-ruby192.dll, not work.

question:
Is there anyone istall command-t plugin, how do you do it?

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: command-t plugin need wrong ruby version

Sand Glass
On Friday, April 21, 2017 at 12:48:01 AM UTC+8, Sand Glass wrote:
> I want to install command-t plugin.(gvim 7.4; windows)
> https://github.com/wincent/command-t
> It needs ruby 1.9.2. I download the right ruby version.
> http://rubyinstaller.org/downloads/archives
> But when I run ':ruby 1' to test ruby. It shows Error "E370  msvcrt-ruby192.dll
>  lost", then I goto the ruby diretory to search the 192.dll, but only msvcrt-ruby191.dll, I tried all 192 ruby verion in above page. All of them 191.dll, I tried to change msvcrt-ruby191.dll to msvcrt-ruby192.dll, not work.
>
> question:
> Is there anyone istall command-t plugin, how do you do it?

command-t is a good plugin, so there should be someone tracked in here.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: command-t plugin need wrong ruby version

Ken Takata-2
In reply to this post by Sand Glass
Hi,

2017/4/21 Fri 1:48:01 UTC+9 Sand Glass wrote:
> I want to install command-t plugin.(gvim 7.4; windows)
> https://github.com/wincent/command-t
> It needs ruby 1.9.2. I download the right ruby version.
> http://rubyinstaller.org/downloads/archives
> But when I run ':ruby 1' to test ruby. It shows Error "E370  msvcrt-ruby192.dll
>  lost", then I goto the ruby diretory to search the 192.dll, but only msvcrt-ruby191.dll, I tried all 192 ruby verion in above page. All of them 191.dll, I tried to change msvcrt-ruby191.dll to msvcrt-ruby192.dll, not work.
>
> question:
> Is there anyone istall command-t plugin, how do you do it?

I think that ruby support of the official Vim 7.4 installer is broken.
Ruby's dll has the API version in its name.  Ruby 1.9.2's API version is 1.9.1.
So the dll name should include 191.  However, strangely Vim 7.4 requires 192.
I think the easiest way to enable ruby support is using Vim 8.0.
(I don't know about command-t.)

Regards,
Ken Takata

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.