dbext version 20 does not prompt for connection profile

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

dbext version 20 does not prompt for connection profile

NJia
Hi Everyone

I just upgraded my dbext plugin from version 19 to 20 but noticed that version 20 does not prompt for connection profiles any more.

I have two MYSQL connection defined in my .vimrc when I type "\slt"  v19 asks me which connection profile I want to use.

But version 20 just display an error message "dbext:A valid database type must be chosen", I have to issue command "\sbp" to select the connection first.

anyway to change this in version 20 ?

thanks

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: dbext version 20 does not prompt for connection profile

David Fishburn-2

On Tue, Oct 29, 2013 at 7:51 AM, NJia <[hidden email]> wrote:
Hi Everyone

I just upgraded my dbext plugin from version 19 to 20 but noticed that version 20 does not prompt for connection profiles any more.

I have two MYSQL connection defined in my .vimrc when I type "\slt"  v19 asks me which connection profile I want to use.

But version 20 just display an error message "dbext:A valid database type must be chosen", I have to issue command "\sbp" to select the connection first.

anyway to change this in version 20 ?


Assuming you have 2 profiles defined in your .vimrc:

let g:dbext_default_profile_A = 'type=ASA:dsnname=cons'
let g:dbext_default_profile_B = 'type=ASA:dsnname=cons_prime'

Hmmm, I believe if you define:
let g:dbext_default_profile = 'A'

Then run your \slt this might pick up the A profile first.

Please let me know.

Thanks for the report, I will look into the issue.

David


--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
 
---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: dbext version 20 does not prompt for connection profile

Stevan Earl
On Wednesday, October 30, 2013 at 8:23:15 AM UTC-7, David Fishburn wrote:

> On Tue, Oct 29, 2013 at 7:51 AM, NJia <[hidden email]> wrote:
>
> Hi Everyone
>
>
>
> I just upgraded my dbext plugin from version 19 to 20 but noticed that version 20 does not prompt for connection profiles any more.
>
>
>
> I have two MYSQL connection defined in my .vimrc when I type "\slt"  v19 asks me which connection profile I want to use.
>
>
>
> But version 20 just display an error message "dbext:A valid database type must be chosen", I have to issue command "\sbp" to select the connection first.
>
>
>
> anyway to change this in version 20 ?
>
>
>
>
> Assuming you have 2 profiles defined in your .vimrc:
>
>
>
> let g:dbext_default_profile_A = 'type=ASA:dsnname=cons'
>
> let g:dbext_default_profile_B = 'type=ASA:dsnname=cons_prime'
>
>
> Hmmm, I believe if you define:
>
> let g:dbext_default_profile = 'A'
>
>
>
> Then run your \slt this might pick up the A profile first.
>
>
> Please let me know.
>
>
> Thanks for the report, I will look into the issue.
>
>
> David

Hi All,

I have just discovered this old post but have run into the same problem with version 23.00 (just installed for the first time). The functionality works fine if I set a default profile but it will connect only to that default and I am not prompted to choose among the several profiles that I have included in my vimrc. Was this resolved?

Otherwise, this is quite possibly the greatest vim package in existence.


Thanks,
Steve

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: dbext version 20 does not prompt for connection profile

David Fishburn-2
...
I have just discovered this old post but have run into the same problem with version 23.00 (just installed for the first time). The functionality works fine if I set a default profile but it will connect only to that default and I am not prompted to choose among the several profiles that I have included in my vimrc. Was this resolved?

I will have a look at this soon, thanks for reporting it.
 
Otherwise, this is quite possibly the greatest vim package in existence.

I am glad you are enjoying it.

David
 

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: dbext version 20 does not prompt for connection profile

David Fishburn-2


On Thu, Jul 13, 2017 at 8:24 AM, David Fishburn <[hidden email]> wrote:
...
I have just discovered this old post but have run into the same problem with version 23.00 (just installed for the first time). The functionality works fine if I set a default profile but it will connect only to that default and I am not prompted to choose among the several profiles that I have included in my vimrc. Was this resolved?

I will have a look at this soon, thanks for reporting it.


Stevan,

You indicate you are using version 23.00, but version 25.00 is the current version:

dbext.vim : Provides database access to many DBMS (Oracle, Sybase, Microsoft, MySQL, DBI,..)

Can you please try with it and let me know.

I am testing with the next version 26.00 and it works as expected.

David


--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: dbext version 20 does not prompt for connection profile

Stevan Earl
On Friday, July 14, 2017 at 6:24:54 AM UTC-7, David Fishburn wrote:

> On Thu, Jul 13, 2017 at 8:24 AM, David Fishburn <[hidden email]> wrote:
>
>
>
> ...
> I have just discovered this old post but have run into the same problem with version 23.00 (just installed for the first time). The functionality works fine if I set a default profile but it will connect only to that default and I am not prompted to choose among the several profiles that I have included in my vimrc. Was this resolved?
>
>
>
> I will have a look at this soon, thanks for reporting it.
>
>
>
>
> Stevan,
>
>
> You indicate you are using version 23.00, but version 25.00 is the current version:
>
>
> dbext.vim : Provides database access to many DBMS (Oracle, Sybase, Microsoft, MySQL, DBI,..)
>
> http://www.vim.org/scripts/script.php?script_id=356
>
>
>
> Can you please try with it and let me know.
>
>
> I am testing with the next version 26.00 and it works as expected.
>
>
> David
Hi David,

I have been traveling and apologize for my slow response.

It took me a while to realize that the version on vim.org (v.25) is ahead of the version (v.23) on GitHub. Anyway, got that figured out and updated to version 25. Same behavior. However, I wonder if I have simply been misinterpreting the functionality. One helpful site that led me to this plugin in the first place left me with the impression that the user is prompted for the desired DB connection from the list of connections detailed in the vimrc when you first call dbext in a new buffer. That does not happen. If I run a query, table select, or whatever from dbext, it automatically runs that command using the default DB connection. I can, however, use any DB connection listed in the vimrc if I run \sbp. Upon further reflection, this is probably the way it is intended to work, and I very much apologize for having troubled you if this was simply operator error.


Stevan

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: dbext version 20 does not prompt for connection profile

David Fishburn-2

However, I wonder if I have simply been misinterpreting the functionality. One helpful site that led me to this plugin in the first place left me with the impression that the user is prompted for the desired DB connection from the list of connections detailed in the vimrc when you first call dbext in a new buffer. That does not happen. If I run a query, table select, or whatever from dbext, it automatically runs that command using the default DB connection. I can, however, use any DB connection listed in the vimrc if I run \sbp. Upon further reflection, this is probably the way it is intended to work, and I very much apologize for having troubled you if this was simply operator error.


You can have that desired behaviour, just depends on how you have setup your defaults.

If you put this in your .vimrc:
:let g:dbext_default_profile='@askb'

You are saying, "@askb" = "Ask first time per buffer"

I suspect your g:dbext_default_profile is blank, empty or undefined.

David


--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: dbext version 20 does not prompt for connection profile

Stevan Earl
On Monday, July 17, 2017 at 9:56:59 AM UTC-7, David Fishburn wrote:

> However, I wonder if I have simply been misinterpreting the functionality. One helpful site that led me to this plugin in the first place left me with the impression that the user is prompted for the desired DB connection from the list of connections detailed in the vimrc when you first call dbext in a new buffer. That does not happen. If I run a query, table select, or whatever from dbext, it automatically runs that command using the default DB connection. I can, however, use any DB connection listed in the vimrc if I run \sbp. Upon further reflection, this is probably the way it is intended to work, and I very much apologize for having troubled you if this was simply operator error.
>
>
>
>
>
> You can have that desired behaviour, just depends on how you have setup your defaults.
>
>
> If you put this in your .vimrc:
> :let g:dbext_default_profile='@askb'
>
>
> You are saying, "@askb" = "Ask first time per buffer"
>
>
> I suspect your g:dbext_default_profile is blank, empty or undefined.
>
>
> David
Hi David - Yes, that works beautifully. Thank you! Stevan

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Loading...