gvim editing ruby on Windows

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

gvim editing ruby on Windows

stevehorn
When I try to edit an existing or create a new ruby file with gvim on Windows I get the following error:
----
Error detected while processing C:\Program Files (x86)\Vim\vim73\ftplugin\ruby.vim
line 76:
NoMethodError: undefined method 'synchronize' for #<Mutex:0x4019cc0>
line 93:
E121: Undefined variable: s:ruby_path
E15: Invalid expression: s:ruby_path

Any idea what I might be doing wrong?


_______________________________________________
vim-ruby-devel mailing list
[hidden email]
http://rubyforge.org/mailman/listinfo/vim-ruby-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gvim editing ruby on Windows

Tim Pope-2
Probably a Ruby 1.9 thing. What does `:ruby p RUBY_VERSION` output?

I know there's issues with the omnicomplete plugin. This is the first I've heard of with just the ftplugin.

On Sat, Oct 30, 2010 at 10:19 PM, Steve Horn <[hidden email]> wrote:
When I try to edit an existing or create a new ruby file with gvim on Windows I get the following error:
----
Error detected while processing C:\Program Files (x86)\Vim\vim73\ftplugin\ruby.vim
line 76:
NoMethodError: undefined method 'synchronize' for #<Mutex:0x4019cc0>
line 93:
E121: Undefined variable: s:ruby_path
E15: Invalid expression: s:ruby_path

Any idea what I might be doing wrong?


_______________________________________________
vim-ruby-devel mailing list
[hidden email]
http://rubyforge.org/mailman/listinfo/vim-ruby-devel


_______________________________________________
vim-ruby-devel mailing list
[hidden email]
http://rubyforge.org/mailman/listinfo/vim-ruby-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: gvim editing ruby on Windows

stevehorn

Had ruby 1.8.7 installed along with 1.9.1. Un-installed both and installed 1.9.2 and the error has gone away.

On Oct 31, 2010 11:40 AM, "Tim Pope" <[hidden email]> wrote:
> Probably a Ruby 1.9 thing. What does `:ruby p RUBY_VERSION` output?
>
> I know there's issues with the omnicomplete plugin. This is the first I've
> heard of with just the ftplugin.
>
> On Sat, Oct 30, 2010 at 10:19 PM, Steve Horn <[hidden email]> wrote:
>
>> When I try to edit an existing or create a new ruby file with gvim on
>> Windows I get the following error:
>> ----
>> Error detected while processing C:\Program Files
>> (x86)\Vim\vim73\ftplugin\ruby.vim
>> line 76:
>> NoMethodError: undefined method 'synchronize' for #<Mutex:0x4019cc0>
>> line 93:
>> E121: Undefined variable: s:ruby_path
>> E15: Invalid expression: s:ruby_path
>>
>> Any idea what I might be doing wrong?
>>
>>
>> _______________________________________________
>> vim-ruby-devel mailing list
>> [hidden email]
>> http://rubyforge.org/mailman/listinfo/vim-ruby-devel
>>

_______________________________________________
vim-ruby-devel mailing list
[hidden email]
http://rubyforge.org/mailman/listinfo/vim-ruby-devel
Loading...