installing gvim on xp box -- no context menu in explorer

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

installing gvim on xp box -- no context menu in explorer

Scott C-2
vimmers--

when i build gvim 6.3.86 on my windows xp box i get a pretty new
install.exe, and it seems to install fine, but i do not get the "edit
with vim" options in the explorer context menu like i did with win98

is there something specific to xp i need to do to get those context
menus to appear?

tia,

scott



Reply | Threaded
Open this post in threaded view
|

Re: installing gvim on xp box -- no context menu in explorer

A.J.Mechelynck
----- Original Message -----
From: "scott2237" <[hidden email]>
To: <[hidden email]>
Sent: Sunday, September 04, 2005 9:24 PM
Subject: installing gvim on xp box -- no context menu in explorer


> vimmers--
>
> when i build gvim 6.3.86 on my windows xp box i get a pretty new
> install.exe, and it seems to install fine, but i do not get the "edit
> with vim" options in the explorer context menu like i did with win98
>
> is there something specific to xp i need to do to get those context
> menus to appear?
>
> tia,
>
> scott

I think that the installer needs the following in order to be able to make
the "Edit with Vim" menu items appear in Windows Explorer:

    - The registry must be writable by the install process;
    - gvimext.dll must be installed in the PATH;
    - The user must select the appropriate checkboxes in the Install
process.

There are two kinds of "Edit with Vim" menu items: one of them applies to
all files, the other to only some kinds of text files. IIUC, only one of
them requires gvimext.dll.

If, after checking the above (and possibly taking the necessary steps), you
still cannot make the "Edit with Vim" menu items appear, I suggest the
following:

1. Download and install the 6.3.000 self-installer for W32 from the
"official" Vim site http://www.vim.org/ or http://vim.sourceforge.net/ 
(click "Download" in the left margin). That should take care of the
shortcuts, .BAT files, registry entries, Explorer menu entries, etc.
(provided of course that you check or uncheck the proper checkboxes).
2. Download the 6.3.086 executables and (optional but recommended) the
6.3.081 runtime files from the links on my Vim page
http://users.skynet.be/antoine.mechelynck/vim/ (click 'My "changes" distro'
to get to the relevant paragraph). These are two zipfiles: download them
anywhere you want (for instance on your desktop) then unzip them on top of
each other into the "vim63" folder (typically "C:\Program Files\vim\vim63")
created by the install at step 1. Tell your unzipper to "use folder names"
"overwrite existing files" and "skip older files". This step changes nothing
to shortcuts, registry entries, etc.; it merely replaces some of the 6.3.000
files by more up-to-date versions.

Notes:
    1. According to an email I saw today in this list, the "default"
unpacker that comes with Win XP is not "good enough" to uncompress these
zipfiles; 7zip or WinZip (among others) should be able to do the job.
    2. It is not possible to install a new version of vim.exe or gvim.exe
while there is one running. Close all running instances first.

Best regards,
Tony.