italic fonts

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

italic fonts

Tim Stebbing
It seems that setting gui=italic in a colour scheme on osx using
7.0actually produces underlined text not italic.

--
Timothy J Stebbing
Reply | Threaded
Open this post in threaded view
|

Re: italic fonts

Benji Fisher
On Tue, Jul 18, 2006 at 09:39:20AM +1000, Tim Stebbing wrote:
> It seems that setting gui=italic in a colour scheme on osx using
> 7.0actually produces underlined text not italic.

     I do not see any change at all after

:hi Normal gui=italic

How have you set 'guifont', 'macatsui', and 'antialias'?  What :hi
command do you use?

     This may not be improved until someone who knows what (s)he is
doing overhauls the font-rendering code for OS X.

HTH --Benji Fisher
Reply | Threaded
Open this post in threaded view
|

Re: italic fonts

Tim Stebbing
In my vimrc I do:

autocmd GUIEnter * set nomacatsui anti enc=utf-8 termencoding=macroman
gfn=Monaco:h14

and in the particular colourscheme I was editing:

hi Comment        gui=italic   guifg=#cd8b00   guibg=NONE


On 7/18/06, Benji Fisher <[hidden email]> wrote:

>
> On Tue, Jul 18, 2006 at 09:39:20AM +1000, Tim Stebbing wrote:
> > It seems that setting gui=italic in a colour scheme on osx using
> > 7.0actually produces underlined text not italic.
>
>      I do not see any change at all after
>
> :hi Normal gui=italic
>
> How have you set 'guifont', 'macatsui', and 'antialias'?  What :hi
> command do you use?
>
>      This may not be improved until someone who knows what (s)he is
> doing overhauls the font-rendering code for OS X.
>
> HTH                                     --Benji Fisher
>



--
Timothy J Stebbing
Reply | Threaded
Open this post in threaded view
|

Re: italic fonts

Benji Fisher
     With those settings, I see the same thing.  So at least there does
not seem to be anything weird about your system.  Unfortunately, as I
said in my first reply, this is part of the larger problems with font
rendering.

                                        --Benji Fisher

On Wed, Jul 19, 2006 at 08:38:18AM +1000, Tim Stebbing wrote:

> In my vimrc I do:
>
> autocmd GUIEnter * set nomacatsui anti enc=utf-8 termencoding=macroman
> gfn=Monaco:h14
>
> and in the particular colourscheme I was editing:
>
> hi Comment        gui=italic   guifg=#cd8b00   guibg=NONE
>
>
> On 7/18/06, Benji Fisher <[hidden email]> wrote:
> >
> >On Tue, Jul 18, 2006 at 09:39:20AM +1000, Tim Stebbing wrote:
> >> It seems that setting gui=italic in a colour scheme on osx using
> >> 7.0actually produces underlined text not italic.
> >
> >     I do not see any change at all after
> >
> >:hi Normal gui=italic
> >
> >How have you set 'guifont', 'macatsui', and 'antialias'?  What :hi
> >command do you use?
> >
> >     This may not be improved until someone who knows what (s)he is
> >doing overhauls the font-rendering code for OS X.
> >
> >HTH                                     --Benji Fisher