[patch] 7.3: Prerequisite autoconf 2.62 (or newer)

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[patch] 7.3: Prerequisite autoconf 2.62 (or newer)

Ralf Schandl-3
Hi,

I realised that configure.in is not compatible with autoconf 2.13. The
debian wrapper script uses 2.13 for configure.in by default. By adding
the statement "AC_PREREQ(2.62)" the wrapper script chooses 2.62 or newer.

The attached patch adds this statement and updates the comment.

I've choosen 2.62 as this is named in version7.txt.

- Ralf

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

diff -r a0cce15dd2a9 src/configure.in
--- a/src/configure.in Wed May 26 21:42:54 2010 +0200
+++ b/src/configure.in Sat May 29 12:46:50 2010 +0200
@@ -1,7 +1,7 @@
 dnl configure.in: autoconf script for Vim
 
-dnl Process this file with autoconf 2.12 or 2.13 to produce "configure".
-dnl Should also work with autoconf 2.54 and later.
+dnl Process this file with autoconf 2.62 or later to produce "configure".
+AC_PREREQ(2.62)
 
 AC_INIT(vim.h)
 AC_CONFIG_HEADER(auto/config.h:config.h.in)
Reply | Threaded
Open this post in threaded view
|

Re: [patch] 7.3: Prerequisite autoconf 2.62 (or newer)

Bram Moolenaar

Ralf Schandl wrote:

> I realised that configure.in is not compatible with autoconf 2.13. The
> debian wrapper script uses 2.13 for configure.in by default. By adding
> the statement "AC_PREREQ(2.62)" the wrapper script chooses 2.62 or newer.
>
> The attached patch adds this statement and updates the comment.
>
> I've choosen 2.62 as this is named in version7.txt.

What is it that doesn't work with 2.13?  Perhaps there is an easy fix?

--
Support your right to bare arms!  Wear short sleeves!

 /// Bram Moolenaar -- [hidden email] -- http://www.Moolenaar.net   \\\
///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
\\\        download, build and distribute -- http://www.A-A-P.org        ///
 \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
Reply | Threaded
Open this post in threaded view
|

Re: [patch] 7.3: Prerequisite autoconf 2.62 (or newer)

Ralf Schandl-3
Bram Moolenaar wrote:

> Ralf Schandl wrote:
>
>> I realised that configure.in is not compatible with autoconf 2.13. The
>> debian wrapper script uses 2.13 for configure.in by default. By adding
>> the statement "AC_PREREQ(2.62)" the wrapper script chooses 2.62 or newer.
>>
>> The attached patch adds this statement and updates the comment.
>>
>> I've choosen 2.62 as this is named in version7.txt.
>
> What is it that doesn't work with 2.13?  Perhaps there is an easy fix?
>

Bram, I get the following messages:

configure.in:2261: warning: AC_TRY_RUN called without default to allow
cross compiling
autoconf: Undefined macros:
configure.in:102:    AC_MSG_RESULT(no)
configure.in:1031: AC_MSG_RESULT(not found; disabling Ruby)
..... (around 300 locations)

I searched a little bit around and found that AC_MSG_RESULT should also
be available in autoconf2.13. Hmm -- might be a local installation problem.

- Ralf

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
Reply | Threaded
Open this post in threaded view
|

Re: [patch] 7.3: Prerequisite autoconf 2.62 (or newer)

Bram Moolenaar

Ralf Schandl wrote:

> Bram Moolenaar wrote:
> > Ralf Schandl wrote:
> >
> >> I realised that configure.in is not compatible with autoconf 2.13. The
> >> debian wrapper script uses 2.13 for configure.in by default. By adding
> >> the statement "AC_PREREQ(2.62)" the wrapper script chooses 2.62 or newer.
> >>
> >> The attached patch adds this statement and updates the comment.
> >>
> >> I've choosen 2.62 as this is named in version7.txt.
> >
> > What is it that doesn't work with 2.13?  Perhaps there is an easy fix?
> >
>
> Bram, I get the following messages:
>
> configure.in:2261: warning: AC_TRY_RUN called without default to allow
> cross compiling
> autoconf: Undefined macros:
> configure.in:102:    AC_MSG_RESULT(no)
> configure.in:1031: AC_MSG_RESULT(not found; disabling Ruby)
> ..... (around 300 locations)
>
> I searched a little bit around and found that AC_MSG_RESULT should also
> be available in autoconf2.13. Hmm -- might be a local installation problem.

Sounds like it.  You can download it and re-install it perhaps.  Or
remove the package and add it again.

--
hundred-and-one symptoms of being an internet addict:
121. You ask for e-mail adresses instead of telephone numbers.

 /// Bram Moolenaar -- [hidden email] -- http://www.Moolenaar.net   \\\
///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
\\\        download, build and distribute -- http://www.A-A-P.org        ///
 \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php