[patch] fixed error when building Esperanto dictionary

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[patch] fixed error when building Esperanto dictionary

Dominique Pellé
Hi

I see the following error when trying to build the Esperanto dictionary:

$ vim/runtime/spell/eo
$ aap
Aap: ../../../src/vim ../README_eo.txt -e -c "set ff=unix" -c wq
Aap: Error in recipe "/home/pel/sb/vim/runtime/spell/eo/main.aap" line
25: Shell command returned 1

Attached patch fixes it.

Regards
-- Dominique

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

To unsubscribe, reply using "remove me" as the subject.

fixed-main.aap-eo.patch (618 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [patch] fixed error when building Esperanto dictionary

Bram Moolenaar

Dominique Pelle wrote:

> I see the following error when trying to build the Esperanto dictionary:
>
> $ vim/runtime/spell/eo
> $ aap
> Aap: ../../../src/vim ../README_eo.txt -e -c "set ff=unix" -c wq
> Aap: Error in recipe "/home/pel/sb/vim/runtime/spell/eo/main.aap" line
> 25: Shell command returned 1
>
> Attached patch fixes it.

Thanks, I'll look into it soon.

--
ARTHUR: I've said I'm sorry about the old woman, but from the behind you
        looked ...
DENNIS: What I object to is that you automatically treat me like an inferior...
ARTHUR: Well ... I AM king.
                 "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

 /// Bram Moolenaar -- [hidden email] -- http://www.Moolenaar.net   \\\
///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
\\\        download, build and distribute -- http://www.A-A-P.org        ///
 \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

To unsubscribe, reply using "remove me" as the subject.
Reply | Threaded
Open this post in threaded view
|

Re: [patch] fixed error when building Esperanto dictionary

Dominique Pellé
In reply to this post by Dominique Pellé
Dominique Pelle wrote:

> Hi
>
> I see the following error when trying to build the Esperanto dictionary:
>
> $ vim/runtime/spell/eo
> $ aap
> Aap: ../../../src/vim ../README_eo.txt -e -c "set ff=unix" -c wq
> Aap: Error in recipe "/home/pel/sb/vim/runtime/spell/eo/main.aap" line
> 25: Shell command returned 1
>
> Attached patch fixes it.
I found afterwards that the above minor issue is not specific to the
Esperanto  dictionary. Attached patch fixes the same issue for other
dictionaries.

Regards
-- Dominique

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

Subscription settings: http://groups.google.com/group/vim_dev/subscribe?hl=en

fixed-missing-NONE-spell.patch (9K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [patch] fixed error when building Esperanto dictionary

Bram Moolenaar

Dominique Pelle wrote:

> > Hi
> >
> > I see the following error when trying to build the Esperanto dictionary:
> >
> > $ vim/runtime/spell/eo
> > $ aap
> > Aap: ../../../src/vim ../README_eo.txt -e -c "set ff=unix" -c wq
> > Aap: Error in recipe "/home/pel/sb/vim/runtime/spell/eo/main.aap" line
> > 25: Shell command returned 1
> >
> > Attached patch fixes it.
>
> I found afterwards that the above minor issue is not specific to the
> Esperanto  dictionary. Attached patch fixes the same issue for other
> dictionaries.

Now that I look into this patch, I notice:

diff -r 24100651daa9 runtime/spell/it/main.aap
--- a/runtime/spell/it/main.aap Tue Mar 23 18:22:46 2010 +0100
+++ runtime/spell/it/main.aap Sat Apr 17 20:26:24 2010 +0200
@@ -9,7 +9,7 @@
 SPELLDIR = ..
 FILES    = it_IT.aff it_IT.dic
 
-all: $SPELLDIR/it.latin1.spl $SPELLDIR/it.utf-8.spl ../README_it.txt
+all: $SPELLDIR/it.utf-8.spl ../README_it.txt
 
 $SPELLDIR/it.latin1.spl : $FILES
         :sys env LANG=it_IT.ISO8859-1

Why did you remove the latin1 version of the Italian spell files?

--
Micro$oft: where do you want to go today?
    Linux: where do you want to go tomorrow?
  FreeBSD: are you guys coming, or what?

 /// Bram Moolenaar -- [hidden email] -- http://www.Moolenaar.net   \\\
///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
\\\        download, build and distribute -- http://www.A-A-P.org        ///
 \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
Reply | Threaded
Open this post in threaded view
|

Re: [patch] fixed error when building Esperanto dictionary

Dominique Pellé
Bram Moolenaar wrote:

> Dominique Pelle wrote:
>
>> > Hi
>> >
>> > I see the following error when trying to build the Esperanto dictionary:
>> >
>> > $ vim/runtime/spell/eo
>> > $ aap
>> > Aap: ../../../src/vim ../README_eo.txt -e -c "set ff=unix" -c wq
>> > Aap: Error in recipe "/home/pel/sb/vim/runtime/spell/eo/main.aap" line
>> > 25: Shell command returned 1
>> >
>> > Attached patch fixes it.
>>
>> I found afterwards that the above minor issue is not specific to the
>> Esperanto  dictionary. Attached patch fixes the same issue for other
>> dictionaries.
>
> Now that I look into this patch, I notice:
>
> diff -r 24100651daa9 runtime/spell/it/main.aap
> --- a/runtime/spell/it/main.aap Tue Mar 23 18:22:46 2010 +0100
> +++ runtime/spell/it/main.aap   Sat Apr 17 20:26:24 2010 +0200
> @@ -9,7 +9,7 @@
>  SPELLDIR = ..
>  FILES    = it_IT.aff it_IT.dic
>
> -all: $SPELLDIR/it.latin1.spl $SPELLDIR/it.utf-8.spl ../README_it.txt
> +all: $SPELLDIR/it.utf-8.spl ../README_it.txt
>
>  $SPELLDIR/it.latin1.spl : $FILES
>         :sys env LANG=it_IT.ISO8859-1
>
> Why did you remove the latin1 version of the Italian spell files?

Sorry, that was a mistake on my part.  The latin1 Italian dictionary
should of course be generated.  Glad you spotted it.

I did not indicate in my previous email why main.aap failed without "-u NONE".
My ~/.vimrc contained a mistake "sil! unset g:colors_name"  which should
have been "unlet! g:colors_name".   It silently caused Vim to return an
error code when exiting, and caused main.app scripts to fail since they
run vim without "-u NONE".  I fixed my ~/.vimrc, but it's best if main.aap
scripts do not depend on user's ~/.vimrc (as in proposed patch).

Cheers
-- Dominique

--
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php