t_kB (shift tab) is not set when using st terminal

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

t_kB (shift tab) is not set when using st terminal

phkbphkbphkb
Hi,

I'm not sure if it is a bug in vim, but Shift-Tab is not working on my
machine. For example, it clears the line in command mode instead of
getting back to the previous completion.

I solved the problem using the following workaround (from
http://vim.wikia.com/wiki/Make_Shift-Tab_work):

:exe 'set t_kB=' . nr2char(27) . '[Z'

So the problem is that t_kB is not set by default.

I think it is related to the terminal used, because t_kB is not set on
st (https://st.suckless.org/) but is set on tmux (which has a different
$TERM).

Best regards,
François-Xavier Carton

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

t_kB (shift tab) is not set when using st terminal

phkbphkbphkb
Hi,

I'm not sure if it is a bug in vim, but Shift-Tab is not working on my
machine. For example, it clears the line in command mode instead of
getting back to the previous completion.

I solved the problem using the following workaround (from
http://vim.wikia.com/wiki/Make_Shift-Tab_work):

:exe 'set t_kB=' . nr2char(27) . '[Z'

So the problem is that t_kB is not set by default.

I think it is related to the terminal used, because t_kB is not set on
st (https://st.suckless.org/) but is set on tmux (which has a different
$TERM).

Best regards,
François-Xavier Carton

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: t_kB (shift tab) is not set when using st terminal

Christian Brabandt

On Mo, 04 Jun 2018, phkbphkbphkb wrote:

> Hi,
>
> I'm not sure if it is a bug in vim, but Shift-Tab is not working on my
> machine. For example, it clears the line in command mode instead of getting
> back to the previous completion.
>
> I solved the problem using the following workaround (from
> http://vim.wikia.com/wiki/Make_Shift-Tab_work):
>
> :exe 'set t_kB=' . nr2char(27) . '[Z'
>
> So the problem is that t_kB is not set by default.
>
> I think it is related to the terminal used, because t_kB is not set on st
> (https://st.suckless.org/) but is set on tmux (which has a different $TERM).

And what is the value of $TERM and the option value of echo &term?

Best,
Christian
--
Stilblüten aus Schreiben von Versicherungsnehmern:
Ihre Argumente sind wirklich schwach. Für solche faulen Ausreden
müssen Sie sich einen Dümmeren suchen, aber den werden Sie kaum
finden.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: t_kB (shift tab) is not set when using st terminal

phkbphkbphkb
Le 04/06/2018 à 16:23, Christian Brabandt a écrit :

>
> On Mo, 04 Jun 2018, phkbphkbphkb wrote:
>
>> Hi,
>>
>> I'm not sure if it is a bug in vim, but Shift-Tab is not working on my
>> machine. For example, it clears the line in command mode instead of getting
>> back to the previous completion.
>>
>> I solved the problem using the following workaround (from
>> http://vim.wikia.com/wiki/Make_Shift-Tab_work):
>>
>> :exe 'set t_kB=' . nr2char(27) . '[Z'
>>
>> So the problem is that t_kB is not set by default.
>>
>> I think it is related to the terminal used, because t_kB is not set on st
>> (https://st.suckless.org/) but is set on tmux (which has a different $TERM).
>
> And what is the value of $TERM and the option value of echo &term?
>
> Best,
> Christian
>

$TERM and echo &term are both st-256color.

Also I tested with "TERM=xterm vim" (but actually in st) and t_kB is
set. This confirms that the bug only happens with TERM=st-256color.

Best regards,
François-Xavier Carton

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: t_kB (shift tab) is not set when using st terminal

John Little-4
In reply to this post by phkbphkbphkb
On Monday, June 4, 2018 at 5:08:05 PM UTC+12, phkbphkbphkb wrote:
> ... t_kB is not set on
> st (https://st.suckless.org/)

I think it is.  I downloaded the st-0.8.1.tar.gz from there, extracted st.info, ran
    tic st.info
    TERM=st-256color vim -c 'echo &t_kB'
and it shows ^[[Z. (I ignored the tic warnings about unknown capabilities.)

Maybe your OS-level terminfo is old, try the above.  

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: t_kB (shift tab) is not set when using st terminal

phkbphkbphkb
Le 05/06/2018 à 05:54, John Little a écrit :

> On Monday, June 4, 2018 at 5:08:05 PM UTC+12, phkbphkbphkb wrote:
>> ... t_kB is not set on
>> st (https://st.suckless.org/)
>
> I think it is.  I downloaded the st-0.8.1.tar.gz from there, extracted st.info, ran
>      tic st.info
>      TERM=st-256color vim -c 'echo &t_kB'
> and it shows ^[[Z. (I ignored the tic warnings about unknown capabilities.)
>
> Maybe your OS-level terminfo is old, try the above.
>


You are right. t_kB is set after running the tic command. It is probably
a distribution bug, then.

Thanks!
François-Xavier Carton

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.