vim plugin nvim on linux mint

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

vim plugin nvim on linux mint

Paull Vanhowt
Hey,

I am completely new to linux, python and vim... so I really am hopeless here^^
Just trying to configure vim with plugins etc, all works fine, except:

I have found nvim (https://github.com/cwoac/nvim), which is like notational velocity (http://notational.net/) for linux and microsoft. I have used notational velocity for a short period of time and lots of people say its great, so I thought let's get it.

but it does not work and so I hope one of you could help me out here, because google now actually hates me for using it so much in the last few days, trying to figure out what's wrong...


Terminal shows this, after typing vim :call NVIM_init()

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Code:
Error detected while processing function NVIM_init..<SNR>36_SetupResults:
line    2:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
NameError: name 'vim' is not defined
line    3:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
NameError: name 'vim' is not defined
line    4:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
NameError: name 'vim' is not defined
Error detected while processing function NVIM_init..<SNR>36_DefPython:
line  282:
Traceback (most recent call last):
  File "<string>", line 280, in <module>
  File "<string>", line 117, in populate_initial_buffer
NameError: global name 'buf_results' is not defined
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

then nvim is starting, but nothing is working. Every command results in an error message (not defined)



About my software and system:

Linux Mint 15 (Ubuntu)
vim from Ubuntu/Mint package
All plugins work BUT nvim

Python should be active:
>>>>>>>>>>>>>>>>>>>>>>>>>
:python print "Hello"
<<<<<<<<<<<<<<<<<<<<<<<<<
Hello appears in the vim command line


python and vim version:

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
fabian@fabian-Aspire-7730G ~ $ python --version
Python 2.7.4
fabian@fabian-Aspire-7730G ~ $ vim --version
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Apr  2 2013 09:18:16)
Included patches: 1-547
Modified by [hidden email]
Compiled by buildd@
Huge version with GTK2-GNOME GUI.  Features included (+) or not (-):
+arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
+clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
+conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
+digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
+file_in_path +find_in_path +float +folding -footer +fork() +gettext
-hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
+linebreak +lispindent +listcmds +localmap +lua +menu +mksession +modify_fname
+mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
-mouse_sysmouse +mouse_xterm +mouse_urxvt +multi_byte +multi_lang -mzscheme
+netbeans_intg +path_extra +perl +persistent_undo +postscript +printer +profile
+python -python3 +quickfix +reltime +rightleft +ruby +scrollbind +signs
+smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
+tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title
+toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
+vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim
+xsmp_interact +xterm_clipboard -xterm_save
   system vimrc file: "$VIM/vimrc"
     user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
  system gvimrc file: "$VIM/gvimrc"
    user gvimrc file: "$HOME/.gvimrc"
    system menu file: "$VIMRUNTIME/menu.vim"
  fall-back for $VIM: "/usr/share/vim"
Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/harfbuzz   -pthread -DORBIT2=1 -D_REENTRANT -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/libpng12     -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1     -I/usr/include/tcl8.5  -D_REENTRANT=1  -D_THREAD_SAFE=1  -D_LARGEFILE64_SOURCE=1
Linking: gcc   -L. -Wl,-Bsymbolic-functions -Wl,-z,relro -rdynamic -Wl,-export-dynamic  -Wl,-E  -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,--as-needed -o vim   -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0     -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgthread-2.0 -lgmodule-2.0 -lgobject-2.0 -lglib-2.0   -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -lnsl  -lselinux  -lacl -lattr -lgpm -ldl  -L/usr/lib -llua5.1  -Wl,-E  -fstack-protector -L/usr/local/lib  -L/usr/lib/perl/5.14/CORE -lperl -ldl -lm -lpthread -lcrypt -L/usr/lib/python2.7/config-x86_64-linux-gnu -L/usr/lib -lpthread -ldl  -lutil -lm  -lpython2.7 -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions  -L/usr/lib/x86_64-linux-gnu -ltcl8.5 -ldl -lpthread -lieee -lm -lruby-1.9.1 -lpthread -lrt -ldl -lcrypt -lm  -L/usr/lib  
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<


kind regard,
fabian

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|

Re: vim plugin nvim on linux mint

Reid Thompson
On Wed, 2013-09-11 at 10:08 -0700, Paull Vanhowt wrote:

> Hey,
> 
> I am completely new to linux, python and vim... so I really am hopeless here^^
> Just trying to configure vim with plugins etc, all works fine, except:
> 
> I have found nvim (https://github.com/cwoac/nvim), which is like notational velocity (http://notational.net/) for linux and microsoft. I have used notational velocity for a short period of time and lots of people say its great, so I thought let's get it.
> 
> but it does not work and so I hope one of you could help me out here, because google now actually hates me for using it so much in the last few days, trying to figure out what's wrong...

I use vim for just about all text entry that I do.  However, for what
nvim provides (based on watching the demo video ) I use Zim.
http://zim-wiki.org/  It autosaves, autolinks, provides search, etc.
It's worked very well for me and is crossplatform.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php
 
---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|

Re: vim plugin nvim on linux mint

Lech Lorens
In reply to this post by Paull Vanhowt
On Wednesday, September 11, 2013 7:08:21 PM UTC+2, Paull Vanhowt wrote:

> Hey,
>
>
>
> I am completely new to linux, python and vim... so I really am hopeless here^^
>
> Just trying to configure vim with plugins etc, all works fine, except:
>
>
>
> I have found nvim (https://github.com/cwoac/nvim), which is like notational velocity (http://notational.net/) for linux and microsoft. I have used notational velocity for a short period of time and lots of people say its great, so I thought let's get it.
>
>
>
> but it does not work and so I hope one of you could help me out here, because google now actually hates me for using it so much in the last few days, trying to figure out what's wrong...
>
>
>
>
>
> Terminal shows this, after typing vim :call NVIM_init()
>
>
>
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>
> Code:
>
> Error detected while processing function NVIM_init..<SNR>36_SetupResults:
>
> line    2:
>
> Traceback (most recent call last):
>
>   File "<string>", line 1, in <module>
>
> NameError: name 'vim' is not defined
>
> line    3:
>
> Traceback (most recent call last):
>
>   File "<string>", line 1, in <module>
>
> NameError: name 'vim' is not defined
>
> line    4:
>
> Traceback (most recent call last):
>
>   File "<string>", line 1, in <module>
>
> NameError: name 'vim' is not defined
>
> Error detected while processing function NVIM_init..<SNR>36_DefPython:
>
> line  282:
>
> Traceback (most recent call last):
>
>   File "<string>", line 280, in <module>
>
>   File "<string>", line 117, in populate_initial_buffer
>
> NameError: global name 'buf_results' is not defined
>
> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
>
>
>
> then nvim is starting, but nothing is working. Every command results in an error message (not defined)
>
>
>
>
>
>
>
> About my software and system:
>
>
>
> Linux Mint 15 (Ubuntu)
>
> vim from Ubuntu/Mint package
>
> All plugins work BUT nvim
>
>
>
> Python should be active:
>
> >>>>>>>>>>>>>>>>>>>>>>>>>
>
> :python print "Hello"
>
> <<<<<<<<<<<<<<<<<<<<<<<<<
>
> Hello appears in the vim command line
>
>
>
>
>
> python and vim version:
>
>
>
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>
> fabian@fabian-Aspire-7730G ~ $ python --version
>
> Python 2.7.4
>
> fabian@fabian-Aspire-7730G ~ $ vim --version
>
> VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Apr  2 2013 09:18:16)
>
> Included patches: 1-547
>
> Modified by [hidden email]
>
> Compiled by buildd@
>
> Huge version with GTK2-GNOME GUI.  Features included (+) or not (-):
>
> +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
>
> +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
>
> +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
>
> +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
>
> +file_in_path +find_in_path +float +folding -footer +fork() +gettext
>
> -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
>
> +linebreak +lispindent +listcmds +localmap +lua +menu +mksession +modify_fname
>
> +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
>
> -mouse_sysmouse +mouse_xterm +mouse_urxvt +multi_byte +multi_lang -mzscheme
>
> +netbeans_intg +path_extra +perl +persistent_undo +postscript +printer +profile
>
> +python -python3 +quickfix +reltime +rightleft +ruby +scrollbind +signs
>
> +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
>
> +tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title
>
> +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
>
> +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim
>
> +xsmp_interact +xterm_clipboard -xterm_save
>
>    system vimrc file: "$VIM/vimrc"
>
>      user vimrc file: "$HOME/.vimrc"
>
>       user exrc file: "$HOME/.exrc"
>
>   system gvimrc file: "$VIM/gvimrc"
>
>     user gvimrc file: "$HOME/.gvimrc"
>
>     system menu file: "$VIMRUNTIME/menu.vim"
>
>   fall-back for $VIM: "/usr/share/vim"
>
> Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/harfbuzz   -pthread -DORBIT2=1 -D_REENTRANT -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/libpng12     -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1     -I/usr/include/tcl8.5  -D_REENTRANT=1  -D_THREAD_SAFE=1  -D_LARGEFILE64_SOURCE=1
>
> Linking: gcc   -L. -Wl,-Bsymbolic-functions -Wl,-z,relro -rdynamic -Wl,-export-dynamic  -Wl,-E  -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,--as-needed -o vim   -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0     -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgthread-2.0 -lgmodule-2.0 -lgobject-2.0 -lglib-2.0   -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -lnsl  -lselinux  -lacl -lattr -lgpm -ldl  -L/usr/lib -llua5.1  -Wl,-E  -fstack-protector -L/usr/local/lib  -L/usr/lib/perl/5.14/CORE -lperl -ldl -lm -lpthread -lcrypt -L/usr/lib/python2.7/config-x86_64-linux-gnu -L/usr/lib -lpthread -ldl  -lutil -lm  -lpython2.7 -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions  -L/usr/lib/x86_64-linux-gnu -ltcl8.5 -ldl -lpthread -lieee -lm -lruby-1.9.1 -lpthread -lrt -ldl -lcrypt -lm  -L/usr/lib  
>
> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
>
>
>
>
>
> kind regard,
>
> fabian

This should already be solved. The most recent commit to nvim git repo is as follows and seems to address the same issue you are describing. Update the plugin and it will hopefully work.

The commit:
commit 9636a6b9efe845203c5683a5433d468139de7569
Author: Oliver Matthews
Date:   Sun Sep 8 18:30:13 2013 +0100

    Ensure vim is loaded into python before we attempt to access it. Fixes #14

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|

Re: vim plugin nvim on linux mint

Paull Vanhowt
In reply to this post by Reid Thompson
Am Donnerstag, 12. September 2013 14:28:17 UTC+2 schrieb Reid Thompson:

> On Wed, 2013-09-11 at 10:08 -0700, Paull Vanhowt wrote:
>
> > Hey,
> >
> > I am completely new to linux, python and vim... so I really am hopeless here^^
> > Just trying to configure vim with plugins etc, all works fine, except:
> >
> > I have found nvim (https://github.com/cwoac/nvim), which is like notational velocity (http://notational.net/) for linux and microsoft. I have used notational velocity for a short period of time and lots of people say its great, so I thought let's get it.
> >
> > but it does not work and so I hope one of you could help me out here, because google now actually hates me for using it so much in the last few days, trying to figure out what's wrong...
>
> I use vim for just about all text entry that I do.  However, for what
> nvim provides (based on watching the demo video ) I use Zim.
> http://zim-wiki.org/  It autosaves, autolinks, provides search, etc.
> It's worked very well for me and is crossplatform.

Thanks, I'll try it out!

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|

Re: vim plugin nvim on linux mint

Paull Vanhowt
In reply to this post by Lech Lorens
Am Donnerstag, 12. September 2013 15:09:38 UTC+2 schrieb Lech Lorens:

> On Wednesday, September 11, 2013 7:08:21 PM UTC+2, Paull Vanhowt wrote:
>
> > Hey,
>
> >
>
> >
>
> >
>
> > I am completely new to linux, python and vim... so I really am hopeless here^^
>
> >
>
> > Just trying to configure vim with plugins etc, all works fine, except:
>
> >
>
> >
>
> >
>
> > I have found nvim (https://github.com/cwoac/nvim), which is like notational velocity (http://notational.net/) for linux and microsoft. I have used notational velocity for a short period of time and lots of people say its great, so I thought let's get it.
>
> >
>
> >
>
> >
>
> > but it does not work and so I hope one of you could help me out here, because google now actually hates me for using it so much in the last few days, trying to figure out what's wrong...
>
> >
>
> >
>
> >
>
> >
>
> >
>
> > Terminal shows this, after typing vim :call NVIM_init()
>
> >
>
> >
>
> >
>
> > >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>
> >
>
> > Code:
>
> >
>
> > Error detected while processing function NVIM_init..<SNR>36_SetupResults:
>
> >
>
> > line    2:
>
> >
>
> > Traceback (most recent call last):
>
> >
>
> >   File "<string>", line 1, in <module>
>
> >
>
> > NameError: name 'vim' is not defined
>
> >
>
> > line    3:
>
> >
>
> > Traceback (most recent call last):
>
> >
>
> >   File "<string>", line 1, in <module>
>
> >
>
> > NameError: name 'vim' is not defined
>
> >
>
> > line    4:
>
> >
>
> > Traceback (most recent call last):
>
> >
>
> >   File "<string>", line 1, in <module>
>
> >
>
> > NameError: name 'vim' is not defined
>
> >
>
> > Error detected while processing function NVIM_init..<SNR>36_DefPython:
>
> >
>
> > line  282:
>
> >
>
> > Traceback (most recent call last):
>
> >
>
> >   File "<string>", line 280, in <module>
>
> >
>
> >   File "<string>", line 117, in populate_initial_buffer
>
> >
>
> > NameError: global name 'buf_results' is not defined
>
> >
>
> > <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
>
> >
>
> >
>
> >
>
> > then nvim is starting, but nothing is working. Every command results in an error message (not defined)
>
> >
>
> >
>
> >
>
> >
>
> >
>
> >
>
> >
>
> > About my software and system:
>
> >
>
> >
>
> >
>
> > Linux Mint 15 (Ubuntu)
>
> >
>
> > vim from Ubuntu/Mint package
>
> >
>
> > All plugins work BUT nvim
>
> >
>
> >
>
> >
>
> > Python should be active:
>
> >
>
> > >>>>>>>>>>>>>>>>>>>>>>>>>
>
> >
>
> > :python print "Hello"
>
> >
>
> > <<<<<<<<<<<<<<<<<<<<<<<<<
>
> >
>
> > Hello appears in the vim command line
>
> >
>
> >
>
> >
>
> >
>
> >
>
> > python and vim version:
>
> >
>
> >
>
> >
>
> > >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>
> >
>
> > fabian@fabian-Aspire-7730G ~ $ python --version
>
> >
>
> > Python 2.7.4
>
> >
>
> > fabian@fabian-Aspire-7730G ~ $ vim --version
>
> >
>
> > VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Apr  2 2013 09:18:16)
>
> >
>
> > Included patches: 1-547
>
> >
>
> > Modified by [hidden email]
>
> >
>
> > Compiled by buildd@
>
> >
>
> > Huge version with GTK2-GNOME GUI.  Features included (+) or not (-):
>
> >
>
> > +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent
>
> >
>
> > +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
>
> >
>
> > +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui +diff
>
> >
>
> > +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search +farsi
>
> >
>
> > +file_in_path +find_in_path +float +folding -footer +fork() +gettext
>
> >
>
> > -hangul_input +iconv +insert_expand +jumplist +keymap +langmap +libcall
>
> >
>
> > +linebreak +lispindent +listcmds +localmap +lua +menu +mksession +modify_fname
>
> >
>
> > +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm
>
> >
>
> > -mouse_sysmouse +mouse_xterm +mouse_urxvt +multi_byte +multi_lang -mzscheme
>
> >
>
> > +netbeans_intg +path_extra +perl +persistent_undo +postscript +printer +profile
>
> >
>
> > +python -python3 +quickfix +reltime +rightleft +ruby +scrollbind +signs
>
> >
>
> > +smartindent -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
>
> >
>
> > +tag_old_static -tag_any_white +tcl +terminfo +termresponse +textobjects +title
>
> >
>
> > +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
>
> >
>
> > +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim
>
> >
>
> > +xsmp_interact +xterm_clipboard -xterm_save
>
> >
>
> >    system vimrc file: "$VIM/vimrc"
>
> >
>
> >      user vimrc file: "$HOME/.vimrc"
>
> >
>
> >       user exrc file: "$HOME/.exrc"
>
> >
>
> >   system gvimrc file: "$VIM/gvimrc"
>
> >
>
> >     user gvimrc file: "$HOME/.gvimrc"
>
> >
>
> >     system menu file: "$VIMRUNTIME/menu.vim"
>
> >
>
> >   fall-back for $VIM: "/usr/share/vim"
>
> >
>
> > Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK  -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/harfbuzz   -pthread -DORBIT2=1 -D_REENTRANT -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-keyring-1 -I/usr/include/libgnome-2.0 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/gail-1.0 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gio-unix-2.0/ -I/usr/include/pixman-1 -I/usr/include/libpng12     -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1     -I/usr/include/tcl8.5  -D_REENTRANT=1  -D_THREAD_SAFE=1  -D_LARGEFILE64_SOURCE=1
>
> >
>
> > Linking: gcc   -L. -Wl,-Bsymbolic-functions -Wl,-z,relro -rdynamic -Wl,-export-dynamic  -Wl,-E  -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,--as-needed -o vim   -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0     -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgconf-2 -lgthread-2.0 -lgmodule-2.0 -lgobject-2.0 -lglib-2.0   -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -lnsl  -lselinux  -lacl -lattr -lgpm -ldl  -L/usr/lib -llua5.1  -Wl,-E  -fstack-protector -L/usr/local/lib  -L/usr/lib/perl/5.14/CORE -lperl -ldl -lm -lpthread -lcrypt -L/usr/lib/python2.7/config-x86_64-linux-gnu -L/usr/lib -lpthread -ldl  -lutil -lm  -lpython2.7 -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions  -L/usr/lib/x86_64-linux-gnu -ltcl8.5 -ldl -lpthread -lieee -lm -lruby-1.9.1 -lpthread -lrt -ldl -lcrypt -lm  -L/usr/lib  
>
> >
>
> > <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
>
> >
>
> >
>
> >
>
> >
>
> >
>
> > kind regard,
>
> >
>
> > fabian
>
>
>
> This should already be solved. The most recent commit to nvim git repo is as follows and seems to address the same issue you are describing. Update the plugin and it will hopefully work.
>
>
>
> The commit:
>
> commit 9636a6b9efe845203c5683a5433d468139de7569
>
> Author: Oliver Matthews
>
> Date:   Sun Sep 8 18:30:13 2013 +0100
>
>
>
>     Ensure vim is loaded into python before we attempt to access it. Fixes #14

Hey,
thank you.
But that does not seem to work for me. I have this change in nvim (python import vim, or something like that?). As it did not work, I re-installed vim and nvim, tried an update, but it still does not work out (same error message, even so I have this change in nvim now).

I am starting to think that I am missing some package (like a library) but I really cannot figure it out.

--
--
You received this message from the "vim_use" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

---
You received this message because you are subscribed to the Google Groups "vim_use" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.